Help with FSTAB SMB mounts


#1

Tried the procedure ON VERO 4K doesnt work!!
https://paste.osmc

After that tried installing client as suggested and this is
the terminal log
`Error returning browse list: NT_STATUS_ACCESS_DENIED
Connection to 192.xxxxx failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available
osmc@osmc:~$ smbclient -L xxxxA1 -U
WARNING: The “syslog” option is deprecated
Enter 's password:
Anonymous login successful
Domain=[] OS=[Windows 7 Ultimate 7601 Service Pack 1] Server=[Windows 7 Ultimate 6.1]

Sharename       Type      Comment
---------       ----      -------

Error returning browse list: NT_STATUS_ACCESS_DENIED
Anonymous login successful
Domain=[1] OS=[Windows 7 Ultimate 7601 Service Pack 1] Server=[Windows 7 Ultimate 6.1]

Server               Comment
---------            -------

Workgroup            Master
---------            -------

`


Configuring fstab based Samba share mounts
#2

I moved your post to Help and Support as the Wiki post is for information, not help.

Since smbclient is not returning anything then it looks like something with the server is the problem. First since you have the vers=1.0 option in fstab, is it enabled on Windows?

Did you try

domain=<your domain>

in fstab?


#3

I’ve added vers=1.0 option in fstab beacuse was suggested in the wiki.
It worked before without vers=1.0 option in fstab but since it stopped working i’ve tried this.
Can you better explain how can i try domain=your domain ?


#4

Since vers=1.0 was working then you need to look at the Windows system for what changed then things broke.

As to the domain=your domain, it’s just another option to add to your fstab line just like vers=


#7

This just came to my attention:

That’s probably your problem.


#8

F*** … so no solution?


#9

Hi,

There are a couple of solutions listed the article, they need to made on the WIndows PC.

Thanks Tom.