Help with USB Audio interface

I have a Native Instruments Audio 2 DJ usb interface. It is supposed to support ALSA.

When I go to System Settings - audio, I don’t see any option for the Audio DJ alsa driver. Just HDMI and analog, and some alsa default bcm2835.

Is there anything I can try to get this usb audio interface working?

I happen to have a Focusrite Scarlett interface too. It doesn’t work either. I wonder if this is an issue with my older Raspberry Pi 1, which only has 256MB of ram.

A Pi1 with 256M of ram is very limited in what can be done with kodi (many add-ons and skins will send it into swapping hell due to the limited memory) and upgrading would be recommended.

However it shouldn’t affect the auto card showing up in audio settings. Can you ssh in and report output of:

aplay -l

I went out and upgraded to a Pi3. I still have problems using the NI Audio 2 DJ. Focusrite Scarlett seems to work fine so far.

I can upload a logfile from Or I can try to post the output you’ve asked for. However, I get “command not found” for lsusb and aplay -l. Same goes for sudo lsusb and sudo aplay.


for lsusb do sudo apt-get install usbutils
for aplay I would assume that you had alsa installed as part of activating your usb soundcard. If not do sudo apt-get install alsa-utils

osmc@osmc:~$ lsusb
Bus 001 Device 004: ID 17cc:041c Native Instruments Audio 2 DJ
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

osmc@osmc:~$ lsmod
Module                  Size  Used by
bnep                   12310  2
hci_uart               22713  1
btbcm                   8478  1 hci_uart
bluetooth             425568  22 bnep,btbcm,hci_uart
8021q                  22147  0
garp                    7622  1 8021q
stp                     2430  1 garp
llc                     6031  2 stp,garp
brcmfmac              234779  0
brcmutil                9348  1 brcmfmac
cfg80211              565548  1 brcmfmac
snd_usb_caiaq          40610  0
rfkill                 22502  4 cfg80211,bluetooth
snd_rawmidi            25219  1 snd_usb_caiaq
snd_seq_device          5504  1 snd_rawmidi
bcm2835_wdt             4081  0
bcm2835_gpiomem         4026  0
bcm2835_thermal         2541  0
snd_bcm2835            24938  0
snd_pcm               115812  2 snd_bcm2835,snd_usb_caiaq
snd_timer              26094  1 snd_pcm
snd                    78512  6 snd_bcm2835,snd_usb_caiaq,snd_timer,snd_pcm,snd_rawmidi,snd_seq_device
uio_pdrv_genirq         3885  0
uio                    10428  1 uio_pdrv_genirq
fuse                  108681  1
ipv6                  448018  42

osmc@osmc:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
  card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
  card 1: Audio2DJ [Audio 2 DJ], device 0: Audio 2 DJ [Audio 2 DJ]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

However, in Settings - System - Audio, the Audio 2 DJ is not listed as an option. I can choose between HDMI, analog and Alsa (bcm2835).


I have no experience of the product, but I quickly read-up on the link you gave.

Just to clarify, the link from the Native Instruments site to the ALSA Project site leads you to quite a bit of configuration information. You didn’t mention if you followed it to the letter.

There were also a few things that might be relevant here:

Note also that the kernel module soundcore has been renamed in Debian kernels >2.6.23 into snd. A workaround is to put a symlink at /lib/modules/x.x.xx/kernel/sound/soundcore.ko pointing to snd.ko


Systemd users need to save this information into a file in the /etc/​modprobe.d/ directory terminating with .conf (eg. /etc/​modprobe.d/​alsa.conf).

Just for the avoidance of doubt, OSMC is Debian-based and uses systemd.

Perhaps you could clarify what you have done to configure your system, WRT the information provided on ALSA Project page.

It looks like it is detected as an alsa device. Can you remove the line “dtparam=audio=on” in config.txt so there is only one alsa device and see if that helps.

The Audio 2 DJ is reported to work with ALSA out of the box in linux, so to be honest I did not try to make any changes to the modules or linux kernel.

It’s possible that I have to modify the .asoundrc to explicitly define the outputs, thanks for pointing me in that direction dillthedog.

I’ll also take a look a the config.txt file, thanks popcornmix.

There’s a line on the ALSA site that refers to loading four kernel modules:

modprobe snd-usb-caiaq ; modprobe snd-pcm-oss ; modprobe snd-mixer-oss ; modprobe snd-seq-oss

On my Vero 4K, only the first, snd-usb-caiaq, is present:

osmc@osmc:~$ modinfo snd-usb-caiaq
filename:       /lib/modules/3.14.29-16-osmc/kernel/sound/usb/caiaq/snd-usb-caiaq.ko
license:        GPL
description:    caiaq USB audio
author:         Daniel Mack <>
alias:          usb:v17CCp0808d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp041Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCpBAFFd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp2305d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp041Cd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp0839d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp0D8Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp1915d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp1978d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp0815d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp4712d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp4711d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp1940d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v17CCp1969d*dc*dsc*dp*ic*isc*ip*in*
depends:        snd-rawmidi
intree:         Y
vermagic:       3.14.29-16-osmc SMP mod_unload aarch64
parm:           index:Index value for the caiaq sound device (array of int)
parm:           id:ID string for the caiaq soundcard. (array of charp)
parm:           enable:Enable the caiaq soundcard. (array of bool)
osmc@osmc:~$ modinfo snd-pcm-oss
modinfo: ERROR: Module snd-pcm-oss not found.
osmc@osmc:~$ modinfo snd-mixer-oss
modinfo: ERROR: Module snd-mixer-oss not found.
osmc@osmc:~$ modinfo snd-seq-oss
modinfo: ERROR: Module snd-seq-oss not found.

but there is a snd_pcm and snd_seq_device. I really don’t know enough about the product to know whether the missing modules are necessary.

The only config.txt file I’ve found was in /boot, and it didn’t have the line that you’ve mentioned.

I tried adding the .asoundrc file but it didn’t seem to change anything. It is saved at osmc@osmc:/home/.asoundrc

My Focusrite Scarlett usb audio interface works fine but I really want to use it for something else and keep the Audio 2 DJ for osmc.

Are you using a direct osmc install or NOOBS?
Try adding:

That was interesting. I added dtparam=audio=off and the Audio DJ 2 showed up as an option in system-settings-audio. However, after choosing it, the audio continued to come out through hdmi. I rebooted and osmc reverted to the hdmi output.

I’m using the direct osmc install.

I may have to play with the .asound.rc file a bit more.

FWIW, I just tried a live Ubuntu drive on my PC. Ubuntu 14.04, linux 3.16. The Audio 2 DJ worked out of the box and didn’t have an .asoundrc file. The .asoundrc file might be used by some particular software in linux (Mixx), which obviously I’m not using. .asoundrc may not apply to osmc/kodi.

A bit more info…
I installed OpenElec and it looks to have the same problem as OSMC. Focusrite works, Audio 2 DJ does not.

I then installed Volumio and the Audio 2 DJ works fine. So, Volumio is doing something that OSMC (and openelec) is not.