Help with Windows network access Shared drives

I have read all the Wikis and what I believe are relevant posts here and no joy…
I have a home network that the Vero4K is connected onto.
I wish to access two shared drive directories on a PC being “\\MainPC\Movies” and “\\MainPC\TV Shows” and two directories on my NAS being “\\HomeNAS\Movies” and “\\HomeNAS\TV Shows”.
I have tried everything I can think of and the Vero4K cannot see the shares.

This is via the “Add Network Location” screen using the SMB protocol with (e.g.) Server name = “\\MainPC” and Shared Folder = “\Movies”. The Browse and Browse for new Share do no display anything. I keep ending up with adding “smb://”.
I installed Samba from the store and rebooted… no joy.
The Lan connection is working as I can ping the Vero4K and I can see Youtube videos via the Vero4K.
The shares work fine between the all the (Windows 10) PC connected to the network, just not the Vero4K.
I did try using the IP address of the NAS since it is fixed… no joy there either.

What am I doing wrong ?
Any help appreciated

samba browsing does not work. Known issue.

You don’t need to install samba server on the vero.

There is an issue with different samba versions, which I heavn’t kept up with but there are experts in here like @fzinken

Check your permissions in Win10

Have double checked permissions in Win10 and all are correct.
Password access is not required for the directories I nominated above and “Everyone” has full access.
Is my issue the syntax I am using to nominate the Server name and Shared Folder name ?

Ok, first using guest is not always the easiest so actually creating a user with a password might be a more fool proof solution.
Secondly you might have a tricky environment where your NAS only supports old Samba protocols while your Windows 10 would demand the latest ones.

I think you have two options either follow this thread to change the authentication options via user.conf as explained here

Or more performant follow this thread for fstab based mounting

OK, tried the fstab method but could not get anywhere with that.
Connected a keyboard and was able to get to command line.
The “$ sudo nano /etc/fstab” did not get me anywhere.
The issue will be my total lack of familiarity and knowledge with this operating system.

I then played via the UI. Having a keyboard made this a lot quicker and easier.
Got it all working.
My issue was the syntax in defining the server names. I was using “\” and “” in the entries.
Once I discovered there was no need and also the “C” button context menu I was able to edit and get the access working.

I now have two issues left:-

  • have not been able to get my Harmony One remote working properly
  • and I need to delete one of the main menu items.
    Will persevere.
    Thanks for your help.

What didn’t work? Did you actually type the ‘$’ as part of the command? The standard way in linux to show a command typed at the prompt is to start with $, just like with Windows you normally see C:\ starting a line to be typed.

So what you should have typed was:

sudo nano /etc/fstab

Probably not, there was a “$” on the line before I typed anything and I must have assumed that was the $ so yes I typed “sudo nano /etc/fstab”.
Yes, I know, never assume anything !
As I said, it is lack of knowledge…know zero about Linux.
I won’t go down the fstab path as my shares now work via SMB.
Mind you, knowing Microsoft, a future Win10 update will likely kill that… I’ll revisit then.

I’d like to know why

sudo nano /etc/fstab

did not work for you? What happened when you typed it?

fzinken, thanks for that…
It was 3am and the need for sleep got the better of me.
Thanks for the clue.
Found the Settings area and was able to get rid of everything except Videos, which is all I need, and MyOSMC which I have retained.
All good.

bmillham, I get:-
rootfs is not mounted in fstab as we do it via initramfs. Unmount for remount (slower boot).

As I said above, I am not interested in progressing this.
However, if you wish for me to do this stuff to help you out in any way then would be happy to do so.

As that great sage Harry Callahan said… “A man needs to know his limitations”.
I need to learn more about Linux before touching this stuff.