HEVCs sometimes don't work

So before uploading the logs, I just was wondering if there is a known problem with HEVCs not playing sometimes ?
Sometimes, when I play a HEVC (I see this logo on my skin for the episode) the audio plays, but the video stays black. When I then choose “Audio and toggle passthrough”, the video plays, but 1 frame every few seconds…After soft rebooting, the problem persists, and after cold reboot (power plug, 1-2 times), the video plays fine again.
This did never happen before the November update.

I have converted most of my library to HEVC with no issues.
The Devs will want logs and perhaps Mediainfo output for a file that is not playing.

Which device?

I will upload the logs next time it happens as it doesn’t seem to happen with other people.

It happened again. Here are the logs (debug enabled, soft reboot, tried 3 files that worked previously)

And here is the log after the cold reboot where everything is working fine again:

(Played just one file)

  1. So I tried to compare both logfiles and I didn’t see a noticeable difference.
  2. I changed to HDMI cable going from the Vero to the AV Receiver. Same problem occurred again.
  3. I connected the Vero with a new HDMI cable to another HDMI port on the TV, bypassing the AV Receiver. Same problem occurred again.
  4. I rebooted 4 times via menu (soft reboot) after the problem occurred. No Change. After a hard reboot (Power Plug) , everything was fine again.
  5. So, now I gave up and reinstalled vero from scratch via USB Image

Now I will wait and see if it happens again…


This is happening to me too, and it’s very annoying, did you solve it by reinstalling?
Sometimes it’s only audio and lately no video nor audio. Did you check the system startup looking for any errors?


It happened again. After reinstalling from scratch.
I did not see any big differences in the two log files I posted previously (one where it didn’t work and one where it worked).

So now I am rather clueless.

Perhaps it’s hardware related (is it just always a coincidence that it works after unplugging the device vs soft reboot through the UI) ? Is a hardware decoding chip not initialized properly ?

I really don’t know what to do except replacing the vero with another device ? Perhaps @sam_nazarko has something to add ?

@opflohr & @Poty

I have also been having problems with 2160p videos since the update.
Mine play somewhat different than yours but I suspect that the cause will be found to be the same, or related. That’s if the cause can ever be found.

I think I have the same issue as reported here:

But I still am not sure how to fix it

I’m sure we will work it out. I’m still tackling this, and internally we are also working on a new video stack which will fix some playback problems.

I am not sure what’s unique to your setups to cause this yet.