Hi-Res Audio files buffering/stuttering issue


I wonder if someone could help with the issue that I have from day one - whenever I play hi-res audio files (2-channel stereo) with bit rates 24/48 and above I have music stuttering for a few seconds. After that music plays as normal. To isolate NAS mounting and other possible server related issues, I have plugged in a USB stick with FLAC files directly to Vero 4K. Same issue.

For this test my setup was: Vero 4K → Essence HDACC (via HDMI cable, tried different) → ARCAM A90 (analog sound via RCA cables)

I played two tracks to reproduce the issue:

  1. Eric Clapton ‘So Tired’. Mediainfo: 1883 kb/s, 48.0 kHz, 24 bits, 2 channels, FLAC
  2. The Eagles ‘Hotel California’. Mediainfo: 5159 kb/s, 192 kHz, 24bits, 2 channels, FLAC

Logs: http://paste.osmc.io/rijexosoxu

Any advice will be highly appreciated.

Can you move one of the tracks to /home/osmc and try play from that directory as a quick check?

Sam, thanks for quick response!
I’ve just tried copying one of the tracks to /home/osmc and, unfortunately, no love here. Exactly the same stuttering as when played from USB stick (or from the NAS).

This could be an issue with PAPlayer – which doesn’t buffer audio very well.
I think you can play it with the video player; but you may lose some functionality such as gapless playback.

FWIW I don’t have any trouble playing hires (24/96 and 24/44.1 and I think 24/192 even) FLACs on my Vero4k. They are streamed from my NAS. I use the USB audio out …

Tested So Tired on Kodi v17 and v18, local disc and through network - no probs here.

Check if cpu usage is high, looks like the same issue I got with DSD files and multi channel flacs.

@bluefuzz Although I don’t like using USB for audio out (port is taken by DVB-T2 dongle which frankly, due to its width, occupies space for both USB slots), I tried to give it a go. Firstly, when I connected USB cable to a running Vero 4K it froze immediately and I had to restart it. Upon restart, I changed Audio Out to USB in Settings and this is what happened: I can hear GUI clicking sounds as normal, however when I try to play any standard CD Rips (not Hi-Res), I am getting a message ‘One or more items failed to play. Check the log for more information about this message’. If I try to play any Hi-Res audio track just nothing happens: no messages and no sound except for the GUI click. Bizarre!

Anyway, I would really like to use HDMI port for playing both music and video out of Vero 4K to Essence HDACC. This DAC has HDMI passthrough and it sends video through HDMI output to LG C8.

Any other suggestions?

@grahamh Thank you for checking this, it sounds promising. Did you hook up Vero 4K via HDMI for this test?

I can’t really understand if anything in my logs would shine any light into what could possibly go wrong with my setup. Is there anything that might be different from your setup?

Not really. I know it’s not very helpful, but here ‘it just works’ …

Are you running anything else on the Vero that could be hogging the audio like Raspotify or MPD?

One vero runs through my Yamaha AVR to the TV. Another is plugged into the TV which feeds back to the AVR by ARC (with noticeably poorer sound quality.)