Hifiberry digi+ not working anymore on july release

I’m new to whole raspberry osmc expirience. I really like it. I use a hifiberry digi+ for the sound output. It worked really good with the osmc june release. With the july release it doesnt. The hifiberry digi overlay is selected under hardware. But it doesnt appear under audio output. I can only choose between hdmi and anologe. Now im sad because it used to work with the june release. Do i have to downgrade or is there a fix to get it working?? Thank u very much for ur answer. Best regards -nip


Can you please provide




Please try reseating the card.


Im sorry. What do u mean with reseating the card? The sd card or the hifiberry? thank u

After a chat with @popcornmix, I have found the issue.

This is hopefully fixed in this commit:

It should be with you by the morning as an update

Apologies for the inconvenience caused. I would appreciate it if you let us know if the issue is resolved tomorrow

Many thanks


1 Like

Hi There Sam! I just downloaded an update on my rpi2 and seem to have the same issue. In the settings > audio output menu there is only HDMI and analogue. ALSA output isn’t there anymore.
Keep all the good work!

Please check for updates again and check you’re fully up to date


Hi, after the update my hifiberry can be selected again as audio output. It works and plays sound thru the berry. But i havent tested any more (sound quality for example), yet. Thank u really much for the quick fix. Very much appreciated! Great work!!

You’re welcome – let us know if you have any problems


Thanks Sam! Manually checking for updates fixed the problem. After the update I was able to select the ALSA output in the audio settings.

Had to do a full wipe and new install to get Digi+ working on mine. Forcing manual update didn’t fix it, but full wipe did. Thanks