Hifiberry digi+ not working with January update


hifiberry digi+ not working with January update.

Suggest to check your config.txt and provide logs so that we can help.

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

Same issue here.

Here’s my config.txt :

gpu_mem_1024=256 over_voltage_sdram=0 over_voltage=2 sdram_freq=510 disable_splash=1 dtdebug=1 initial_turbo=0 start_x=1 disable_overscan=1 force_turbo=0 arm_freq=1000 core_freq=500 hdmi_ignore_cec_init=1 #max_usb_current=1 decode_WVC1=0x457d467e gpu_mem_256=112 dtoverlay=hifiberry-digi-overlay sdtv_aspect=1 gpu_mem_512=144

“dmesg” show this

[ 5.866380] snd-hifiberry-digi sound: ASoC: CPU DAI (null) not registered [ 5.866412] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517 [ 5.868622] snd-hifiberry-digi sound: ASoC: CODEC DAI wm8804-spdif not registered [ 5.868655] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517 [ 5.875321] snd-hifiberry-digi sound: ASoC: CODEC DAI wm8804-spdif not registered [ 5.875361] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517 [ 5.884623] bcm2708_i2c 3f804000.i2c: BSC1 Controller at 0x3f804000 (irq 83) (baudrate 100000) [ 5.884887] snd-hifiberry-digi sound: ASoC: CODEC DAI wm8804-spdif not registered [ 5.884911] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517 [ 5.885594] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000 [ 5.885794] snd-hifiberry-digi sound: ASoC: CODEC DAI wm8804-spdif not registered [ 5.885819] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517 [ 5.923075] snd-hifiberry-digi sound: ASoC: CODEC DAI wm8804-spdif not registered [ 5.923125] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517 [ 6.101582] wm8804 1-003b: revision E [ 6.105560] snd-hifiberry-digi sound: wm8804-spdif <-> 3f203000.i2s mapping ok

Can it be related to ALSA being set by default on RPI ? I’ve noticed that in Kodi, my ALSA device name has changed to “bcm2835”


I’m experiencing the same issue with my Hifiberry DAC+ since I did the update an hour ago

  • No sound from the Hifiberry DAC
  • Issue happened after updating OSMC
  • I’m running OSMC on a raspberry Pi 2
  • Peripherals:
    – USB IR receiver (Chinavasion CSVB 983)
    – Samsung TV
    – Marantz Amp

I’ve uploaded all the logs here:


Same here.

Was working fine last night through hifiberry digital card with optical cable to Hi fi.

Realised today that sound was coming out of TV rather than Hi fi.

Checked settings>system>audio output was still set to alsa. But can’t get into my osmc>pi config to check the options there. All the options work in the menu app store etc but selecting pi config does nothing.

1 Like

That fixed the issue for me. (Raspberry Pi 2 + Hifiberry DAC+ + OSMC)

Sound is back :slight_smile: unfortunately AC3 is still not working with my old Sony STR-DB930 :-(. DTS is working fine. Still a kodi bug that needs to be resolved :slight_smile:

Hello, after upgrading my hifiberry digi+ doesn’t work anymore. I added the dtparam=audio=off and saw that the salsa was changed to the snd_rpi_hifiberry_digi S/PDIF. But still no sound. Also the analogue sound gives a lot off noise but no actual sound.

Has anyone an idea?

check your audio settings in Kodi, mine works with digi+ (so it seems)
you need dtparam=audio=off in your config.txt and reboot off course

I saw in the kodi audio settings that the pass though device wasn’t set correctly. It now works fine. Thanks for the support.

Using the config.txt command seems to have sorted out the sound issue now. And ALSA name has returned to hifiberry, correctly.

Still can’t get into the pi config menu though…

Does not seem to work for me though. I have a DAC+ card and it stopped working. I added dtparam=audio=off to config.txt and tried both dtoverlay=hifiberry-dacplus and dtoverlay=hifiberry-dacplus-overlay, but the card will not initialise:

[ 8.302166] bcm2708_i2c 20804000.i2c: BSC1 Controller at 0x20804000 (irq 77) (baudrate 100000)
[ 8.407269] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[ 8.407303] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517

Any ideas?

FWIW, I installed alsa-utils and they say:

osmc@pi:~$ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0
Subdevices: 1/1
Subdevice #0: subdevice #0

Edit: So, now it works, despite the error message in dmesg. FWIW, my config.txt is below. I have a HiFiBerry DAC+


Thanks, solved my issue with the DAC + pro also. (Pi2, DAC+ pro, OSMC jan)

Will this fix be included in a future version of OSMC?

Sam? Do you have a HifiBerry card to test with. I mean for future releases as that card is pretty common. If not, then iI would gladly send you one :slightly_smiling:

I have the issue as well. The dtparam=audio=off line did solve the issue partially. The Hifiberry DAC+ is selectable as sound device in OSMC. However there’s still no sound at all.

Note: I had found a way to solve the issue myself by blacklisting snd_bcm2835 manually, I undid that when I found the “official” fix.
I suspect the official fix does just that. It prevents the snd_bcm2835 module from loading.

Here’s a test with mplayer:

mplayer 01\ A\ Dream\ that\ is\ more\ Scarlet\ than\ Red.ogg 
Creating config file: /home/osmc/.mplayer/config
MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team
Cannot open file '/home/osmc/.mplayer/input.conf': No such file or directory
Failed to open /home/osmc/.mplayer/input.conf.
Cannot open file '/etc/mplayer/input.conf': No such file or directory
Failed to open /etc/mplayer/input.conf.
Failed to read LIRC config file ~/.lircrc.

Playing 01 A Dream that is more Scarlet than Red.ogg.
Detected file format: Ogg (libavformat)
[ogg @ 0x75d275b8]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: audio (vorbis), -aid 0, A Dream that is more Scarlet than Red
Load subtitles in .
Selected audio codec: Vorbis [libavcodec]
AUDIO: 44100 Hz, 2 ch, floatle, 192.0 kbit/6.80% (ratio: 24000->352800)
AO: [pulse] Init failed: Connection refused
[AO_ALSA] Format floatle is not supported by hardware, trying default.
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
[AO_ALSA] Unable to find simple control 'Master',0.
Video: no video
Starting playback...
A:  10.0 (09.9) of 75.4 (01:15.3)  3.1% 

Exiting... (End of file)

Note that when I play a sound and the HifiBerry DAC+ is powered down (which happens after a minute of activity) a soft ‘pop’ sound can be heard through the speakers as it powers up. Also sound over HDMI works fine. It’s just that it’s going to a horrible beamer speaker.
Somehow it almost works.

solves also for me. Thank you

I had a similar issue with the Raspyplay4 DAC with the latest upgrade, dtparam=audio=off did the fix.

Likewise I had lost the sound from my HiFiBerry DAC + after a recent update, thanks for all the hints in this thread which helped me fix the problem. Again “dtparam=audio=off” fixed the problem.

These add on boards are not exactly plug and play are they?

In our February update we automatically set this parameter to off when you select an I2S DAC

They are pretty plug and play

The OSMC DAC will obviously be the best when we launch it soon :wink: