HifiBerry Digi+ stopped being recognized after May Update on RPI 3

Hi Sam,

I have just discovered that my hifiberry digi+ stopped being recognized after the may update.

I looked into the config.txt and the option dtoverlay=hifiberry-digi-overlay and dtparam=audio=off are there.

something has changed with this new kernel.

Fount this entry on boot:

[ 4.357919] snd-hifiberry-digi soc:sound: ASoC: CODEC DAI wm8804-spdif not registered - will retry

This message repeat a couple of times. There is no error message given. at least AFAIK.

Can you the paste the full log so we can see the details?

Thanks

Sure.

Here it is:

https://paste.osmc.tv/azosenakiy

Hi !

I have the same problem I think (?).

In the Pi config I can select the hifiberry-overlay but it’s not present in kodi audio configuration ; is this the same for you ?

Thx

L.

@LudoL0th debug logs

@hbbs

[    4.357919] snd-hifiberry-digi soc:sound: ASoC: CODEC DAI wm8804-spdif not registered - will retry
[    4.453220] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

seems like it didnt registered properly mind posting more then just the kernel log ?

oh and your fat partition ie /boot/ might be dirty

sudo -s
umount /boot
fsck.fat -V /dev/mmcblk0p1
fsck.fat -a /dev/mmcblk0p1
mount /boot

will look something like this.

osmc@Livingroom:~$ sudo -s
root@Livingroom:/home/osmc# umount /boot
root@Livingroom:/home/osmc# fsck.fat -V /dev/mmcblk0p1
fsck.fat 3.0.27 (2014-11-12)
0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
1) Remove dirty bit
2) No action
? 1
Starting check/repair pass.
Starting verification pass.
Leaving filesystem unchanged.
/dev/mmcblk0p1: 267 files, 44367/489976 clusters
root@Livingroom:/home/osmc# fsck.fat -a /dev/mmcblk0p1
fsck.fat 3.0.27 (2014-11-12)
0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
 Automatically removing dirty bit.
Performing changes.
/dev/mmcblk0p1: 267 files, 44367/489976 clusters
root@Livingroom:/home/osmc# mount /boot

there is also an open issue for the Raspberry Kernel team from Hifiberry

that the 4.9 kernel has an issue so best is just wait until it gets merged think that wont be soon off

maybe @popcornmix can be off some futher assistance in this issue.

All logs say that.

Doesnt do harm to fix since its an easy fix

1 Like

Same problem here, but with HiFiBerry DAC+ pro.
Updated today and sound from DAC stopped (the onboard 3.5mm analogue jack still outputs audio)
The entries dtoverlay=hifiberry-dacplus-overlay and dtparam=audio=off are present in config.txt

Exact same problem as Rhumbus with my HiFiBerry DAC+ after May update on my Pi3. Config.txt entries correct but not even getting the option to choose ALSA: HiFiBerry DACPlus in my audio output device, only HDMI or analog or both.

Guys, debug logs please! this isnt really helping anyone if you dont supply logs.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Here is my log:
https://paste.osmc.tv/wogifewere

That issue is resolved and closed. It only affected HifiBerry Amp+, not the more common DAC/Digi.
There are no known problems with I2S audio cards on latest 4.9 kernel.

Kewl, still alot of users here that cant use their hifiberry that doesnt get registered by the pi

Jun 06 11:41:07 osmc kernel: snd-rpi-hifiberry-dacplus soc:sound: ASoC: CPU DAI (null) not registered - will retry
Jun 06 11:41:07 osmc kernel: snd-rpi-hifiberry-dacplus soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry

any clue what thats about ?

Forgive my Noobness please, but how can I pull a clean log like you did?
I enabled logging in OSMC, but my osmc/.kodi/temp/kodi.log (after restart) is not as savory as yours. I also couldn’t find the HiFiBerry entries within the log, even though I enabled a verbose log for the Audio component.

I suspect it is missing kernel config options. My guess is the lack of:
CONFIG_REGULATOR_FIXED_VOLTAGE=m
CONFIG_REGULATOR_ARIZONA=m

(some info here)

I will build a kernel with these changes if anyone is willing to try.

Cheers

Sam

I’ve got the same problem:

[ 6.587513] snd-hifiberry-digi soc:sound: ASoC: CODEC DAI wm8804-spdif not registered - will retry
https://paste.osmc.tv/opumuwikal

Also i2c doesn’t seem to work anymore (I need it for my character LCD), which also relies on an overlay.

Is there any way to downgrade/revert to the previous kernel until this issue is resolved? I really want and need my optical out back for audio…

its better to try and help Sam instead with kernel testing rather then downgrade

Hi,

today I upgrade my osmc on RPI2 and have the same issue.

https://paste.osmc.tv/ogohaximir

No wm8804-spdif module and no device in aplay -l.

osmc@osmc:~$ aplay -l aplay: device_list:268: no soundcards found...