HifiBerry Digi+ stopped being recognized after May Update on RPI 3

wait for testbuild of a new kernel and help Sam try it out see if that fixes the issue

I’m willing to try a new kernel, if I can get it today. Don’t get me wrong, I’m all about testing and helping, but this update broke my mediacenter, which I really need to get running again.

A simple downgrade will fix that for now and will help a lot of other users who don’t have the knowhow or time to try experimental builds…

And to be honest, it appears to be a known issue from about 2 weeks ago affecting not only the Hifiberry, but a lot of soundboards, so how is it possible OSMC pushed this flawed kernel as a stable update?

There will be a kernel for you to test within 20 minutes, if that’s good enough for you.
Otherwise you can downgrade, but keep in mind that 4.4 isn’t supported and there are a lot of key fixes in 4.9.

I was not aware of any issues with HifiBerry DACs.
I believe the issue is actually a missing driver for the voltage regulator, and not related to the above issue at all. Nonetheless, I have picked the PCM commit to include in OSMC anyway.

It isn’t support for 4.4 that’s the issue, it’s the fact that 4.4 was running stable and 4.9 (for now) broke my mediacenter. The normal thing to do in that situation is to downgrade back to the last known good version (4.4) until the issue is solved.

But please let me know when the kernel is ready (and how to install it, because the way the RPi handles kernel-images is a bit different from what I’m used to with desktop versions of Linux…)

Well – we try and test as much hardware as possible, but there are limits. We did have a 4.9 testing thread and we received positive reports from it.

The problem is with your downgrade approach is that if everyone just decides to downgrade, then the problem never gets solved, or worse, problems are only found later when more users upgrade.

You can downgrade via APT, but it’s not recommended.

I will try new kernel and test it. Plz send info, when it will be accessible.

it didnt break its just missing some stuff so keep calm wait 20 min and Sam will post instructions that goes for all of the hifiberry users that got issues on this thread.

Hi,

is the testing kernel ready? I didn’t received anything from Sam.

Thanks for offering to test this kernel. It took some time to build it.

You can try it as follows:

wget "https://www.dropbox.com/s/uaimeepufmaf825/rbp2-image-4.9.29-4-osmc.deb?dl=1" -O kernel.deb
sudo dpkg -i kernel.deb
sudo reboot

Please feedback.

Not working.

https://paste.osmc.tv/uzufiqikoy

[ 5.304308] snd-hifiberry-digi soc:sound: ASoC: CODEC DAI wm8804-spdif not registered - will retry

osmc@osmc:~$ aplay -l aplay: device_list:268: no soundcards found...

Can you paste your config.txt?

osmc@osmc:~$ wget "https://www.dropbox.com/s/uaimeepufmaf825/rbp2-image-4.9.29-4-osmc.deb?dl=1" -O kernel.deb
--2017-06-06 14:48:52--  https://www.dropbox.com/s/uaimeepufmaf825/rbp2-image-4.9.29-4-osmc.deb?dl=1
Translacja www.dropbox.com (www.dropbox.com)... 162.125.66.1
Łączenie się z www.dropbox.com (www.dropbox.com)|162.125.66.1|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 302 Found
Lokalizacja: https://dl.dropboxusercontent.com/content_link/rWFeFYMgBqM74B87ThNjczs6SwbOX1VHRUfj7BYaaWL6a5VgIAXNGlAqMyEvmr7S/file?dl=1 [podążanie]
--2017-06-06 14:48:53--  https://dl.dropboxusercontent.com/content_link/rWFeFYMgBqM74B87ThNjczs6SwbOX1VHRUfj7BYaaWL6a5VgIAXNGlAqMyEvmr7S/file?dl=1
Translacja dl.dropboxusercontent.com (dl.dropboxusercontent.com)... 162.125.66.6
Łączenie się z dl.dropboxusercontent.com (dl.dropboxusercontent.com)|162.125.66.6|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 200 OK
Długość: 19503718 (19M) [application/x-debian-package]
Zapis do: `kernel.deb'

kernel.deb                        100%[============================================================>]  18,60M  5,51MB/s   w  3,5s

2017-06-06 14:48:58 (5,25 MB/s) - zapisano `kernel.deb' [19503718/19503718]
osmc@osmc:~$ sudo dpkg -i kernel.deb
(Odczytywanie bazy danych ... 34862 pliki i katalogi obecnie zainstalowane.)
Przygotowywanie do rozpakowania pakietu kernel.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/001-preprocess-rbp 4.9.29-4-osmc /boot/vmlinuz-4.9.29-4-osmc
Done.
Rozpakowywanie pakietu rbp2-image-4.9.29-4-osmc (4) nad (4) ...
Examining /etc/kernel/postrm.d .
Konfigurowanie pakietu rbp2-image-4.9.29-4-osmc (4) ...

 Hmm. There is a symbolic link /lib/modules/4.9.29-4-osmc/build
 However, I can not read it: Nie ma takiego pliku ani katalogu
 Therefore, I am deleting /lib/modules/4.9.29-4-osmc/build


 Hmm. The package shipped with a symbolic link /lib/modules/4.9.29-4-osmc/source
 However, I can not read the target: Nie ma takiego pliku ani katalogu
 Therefore, I am deleting /lib/modules/4.9.29-4-osmc/source

Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.9.29-4-osmc /boot/vmlinuz-4.9.29-4-osmc
run-parts: executing /etc/kernel/postinst.d/inform-updater 4.9.29-4-osmc /boot/vmlinuz-4.9.29-4-osmc
run-parts: executing /etc/kernel/postinst.d/process-vmlinuz-rbp 4.9.29-4-osmc /boot/vmlinuz-4.9.29-4-osmc
osmc@osmc:~$ sudo reboot
Connection to osmc closed by remote host.
Connection to osmc closed.

Not working for me either, sam.

here’s my config.txt:

gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
dtparam=audio=off
dtoverlay=hifiberry-digi-overlay
gpu_mem_256=112
sdtv_aspect=1
gpu_mem_512=144
dtparam=audio=off

It is in https://paste.osmc.tv/uzufiqikoy in section “Pi config”

gpu_mem_1024=256  
hdmi_ignore_cec_init=1  
disable_overscan=1
start_x=1  
disable_splash=1
gpu_mem_256=112  
dtoverlay=hifiberry-digi-overlay
dtparam=audio=off
sdtv_aspect=1  
sdtv_mode=2  
gpu_mem_512=144  
max_usb_current=1
dtparam=audio=off

.

Any ideas?

Take a chill pill and let Sam figure it out, asking every 5 min wont make it work faster… if your in a huge hurry downgrade instead…

1 Like

I’ll wait.

I don’t have a system to test this for real, but with a bit of driver hackery the soundcard initialises OK.

Can you run modprobe i2c_bcm2835?

osmc@osmc:~$ sudo modprobe i2c_bcm2835
modprobe: FATAL: Module i2c_bcm2835 not found.
$ sudo modprobe i2c_bcm2835
modprobe: FATAL: Module i2c_bcm2835 not found.