High bitrate UHD files stops for buffering

I’ve noticed UHD blu-ray remux of John Wick Chapter 2 which got fairly high bitrate tend to stop at the end. I runs flawless via gigabit ethernet (USB) until it reaches 1 hour and 52 minutes. Then it starts stuttering; then stops before it complains about low read-speed. If I run the same file on other units it works flawless. Even stopping it and restarts makes it stutter. If I restart Vero 4K, then skips to 1 hour and 50 minutes it plays the rest perfect.

Do we have an issue with high bitrate over time on Vero 4K?

It does not seem to matter if it is fstab NFS; or samba connection handling via kodi.

This issue kills the movie experience completely.

I think this is one of the troublesome movies that had been discussed in other thread. Maybe check if any of that is similar to your experience

We fixed John Wick 2 / Serenity stuttering issues about two months ago. They used to occur one or two minutes in to the movie.

The issue at 1hr52 is new. Can others reproduce?

If so, a debug log and small sample to reproduce is needed for us to fix the issue.

Do you experience the problem when playing from a USB drive?


A small sample is kind of impossible; since it requires to run for a long time (it does not fail at the same place every time); but last 2 test-runs it passed 1 hour and 50 minutes.

Before it fails; buffer read-ahead stops. Even though there are little load on the NAS (I can even copy files from NAS (same share) from different computer when it stops pre-reading buffer (it still plays for a while).

Maybe open a SSH session to the Vero4k in parallel and have ping to the NAS from the Vero4k running to see if you get any connection issue around that time.
Also as @sam_nazarko a debug enabled log might give some clue why the buffer runs out.
While strange part is that I understand you that also pressing stop and start doesn’t make it play smooth afterwards, or?

I´ve seen the complete movie last month, have also a gigabit usb lan adapter connected and with the setting

echo 12 | sudo tee /sys/module/amvdec_h265/parameters/dynamic_buf_num_margin

i haven´t any problems or stutterings!

Thanks to your fine bit of testing, it’s now set to 12 in the latest release.

osmc@osmc-4k:~$ cat /sys/module/amvdec_h265/parameters/dynamic_buf_num_margin
1 Like

cat /sys/module/amvdec_h265/parameters/dynamic_buf_num_margin

seem to keep the pre-read buffer around 180 MB/s all the time. On extreme bitrate peeks it drops to 150 MB/s. I am running through John Wick Chapter 2 again to see if it works out all the way to the end.

Wasn’t this already part of latest version? Don’t get it; for me it looks to handle buffering completely different now.

It is already a default value in OSMC

Ran it completely through once more; worked fine - but from 1:52 (even when jumping directly) it seems to struggle with buffering (read ahead is dropping to almost 0 until the credits pop up - then it is back to 180 MB/s again. Maybe there is something weird with this specific movie?

I also tested with ping to my NAS-box (from Vero 4K) while read ahead buffer were dropping; all good on ping.

There are two problems with the dynamic buffer margin being increased. Read-ahead performance seems to take a hit, which seems to effect skipping significantly, and pull-up correction sometimes goes wonky.

I’d be interested to know if lowering the value to 10 changes things for you



@sam_nazarko: I can try; what was the value set to before it got changed to 12 ?

The previous value was 10, but wasn’t high enough for very high rips like Serenity and Terminator 2.

10 is no good; easy test is to skip to chapter 15 and wait and pause til the buffer is filled. 12 seems to do the trick (but it is close to getting buffer read ahead to 0 (which is not good).

Also tried 14; which was really not good (a lot of stuttering). Set it back to 12 again.

But to me it is kind of weird that read ahead buffer gets close to 0 MB/s. This must be a generic bug that should be fixed.

Dunkirk UHD bluray rip got buffer issues between 41 minutes and 42 minutes, even if I start directly here. Same every time. Read ahead buffer goes against 0MB, seems to be something with this specific part of the movie. Similar issue I see on John Wick 2 on chapter 15 (last chapter of movie before the credits).

Hi Tor,

There are some improvements in the works, but it will take a few weeks.


1 Like

@sam_nazarko: Thank you for the great work. Currently Vero 4K is close to the perfect media-box. If you are able to get the UHD material work in the same flawless way as 1080p stuff I would be very happy. Still too many issues with UHD material in my opinion, but the blu-ray players also struggle. Stuff seems to become iffy on Vero 4K when video bitrate exceeds 90 Mb/s for a while, even with USB gigabit adapter. When testing I get around 20MB/s, which should be more than enough.

I have also noticed rewind on high bitrate UHD movies; gets the Vero 4K in trouble. Constant stuttering if you rewind; it does not seems to get in shape regarding buffer after such operation. Fast forward is fine.

Same movies play fine on Oppo UDP 203 over network.

Hi Tor,

There are some changes we made to fix some stuttering with John Wick 2, Terminator 2. This makes FF/RW less capable as we have to take more aggressive buffering.

We will definitely get playback performance where it should be though, but we need a bit of time. There are a few things we have to work on and this is usually one of our busiest months.

I will keep you updated and let you know when there is more testing available.


1 Like

Connecting the share via fstab helps a bit here, but we need more as you already know. Good that work is being done here - ready for testing updates when they are available.

If you are watching 4K UHD content and you can stick with fstab, I recommend it.