/home/osmc/ permissions for user osmc

I mounted a HDD, which is connected to a Router, in fstab.
The mount points to the folder /home/osmc/Record.
This works so far. But i can’t get write permissons for the user osmc.
I can write to the folder with ‘sudo’ and when im logged in as root.

I’m not that familiar with Linux but i read and tried a lot all the evening.
I tried ‘sudo chown osmc:osmc /home/osmc/Record/’ and ‘sudo chmod 777 /home/osmc/Record/’
but i cant get write access.

This mount is for Tvheadend Recordings.

Please could anyone help me out with my new RasPi.

THX in advance

What does your fstab look like? Is the server a Windows system?


// /home/osmc/Record cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=++user++,password=++pass++,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

Server is a Router.

edit: But i think the fstab mount works… i can write to it with sudo and as root and i see the changes on the HDD

edit2: The Tvheadend Server is on the Raspi

OK. Problem solved.
Just restartet the Pi and everything works…