Home Screen is Blank

After last update I was getting a Master user profile box and checked out why it was coming on and if I could get rid of it. I did something to cause the Home Screen to go blank with just the black banner across the middle of the screen. I got into settings: skin ( Confluence) and checked the video, music buttons in the Home Screen settings and ended up with nothing. Although they are not visible I can access weather, music and the General services window on the black banner but I can not access settings. I can access video addons through the favorites star at the bottom left. Can I get this back to original settings?

Try changing the theme back to osmc standard and see if it helps

Or try reinstalling your theme

Thank you for responding . I can’t try those steps because I can not enter “settings”, I can only use remote to enter “music”, “”games” or the ”General” settings page that has selections for General, Control, UPnP/DLNA, Airplay, SMB client and Weather. i can get the addons window which has the Indigo program which I have not used any utilities there. I suppose , and I know little how the Vero works, that I can readjust something with SSH, I have no idea what but I did make changes on my AppleTV that way a few times. Thanks, again.

Yes you can see

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

When connected to SSH try this

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

I’m not so sure going scorched earth is required. You should be able to open the settings via ssh by running the following command…

kodi-send -a "activatewindow(settings)"

If things are really buggered up and one wanted to just get back to default skin settings then they could use these commands at the terminal…

kodi-send -a "Skin.ResetSettings"
kodi-send -a "reloadskin()"

I just tried this with Confluence and it seemed to work as expected.

1 Like

Thanks a lot guys , I got my vero back to the original settings.

fzinken, using the “mediacenter” commands I got an “invalid command” and I am not any less thankful for that , Thank You

Darwin , using the skin resetting/reload skins commands worked and I want to thank you very much.
Both of you helped me a couple of months ago with my noisy external drive problem
(the drive later failed ) and I will complete that topic now also ,Thanks again with that one.


I’m happy to help and glad you got it going, but…

just for the record, I think you must have typed something in wrong because what he posted has been vetted by quite a few different people.

1 Like

It was more likely my error I should have mentioned that, sorry ,I certainly did not mean to offend . In fact I was having a problem getting the SSH window to work with the usb keyboard and switched to the putty program, so I actually did not give the first option a chance to work. Thanks for pointing that out because being a novice ,and elderly now, I appreciate all the help I can get.

No offense. I just wanted to point this out for anyone who might run across this thread in the future. If you need to SSH in the future and your using an updated Windows 10 PC you don’t need to mess with putty. You can just hit the start menu, type “cmd”, hit enter, and then in the windows terminal you can type in…

ssh osmc@192.168.x.x

and hit enter. Inserting the actual ip address of your Vero of course. Microsoft added ssh to Windows last year.

Good to know , I do have Win 10,
Thanks again,