Hoping for some Linux help with my Vero4K

First, apologies if this not the place to ask it, but it is Vero 4K related, so I figured I’d give it a shot.

I’ve been trying to get rid of my satellite TV and go OTA (Over The Air for those who don’t understand all the acronyms being thrown around here) only. I’ve managed to get that going, but am having issues with the EPG (Electronic Program Guide - aka the TV Guide) I’m using with TVHeadend which I am using to record shows, etc.

I followed the instructions here and am finding that it doesn’t work that great. Also, as I read further, it seems that something changed on the zap2it.com website that broke this program and it hasn’t been and might never be updated.

Anyway, I’m trying to uninstall what I installed according the above link, but, I’m not a Linux guy and it’s not as easy as clicking on Uninstall in Windows.

Can anyone walk me through undoing what I did to install this in the first place? Does anyone else have advice on setting up OTA recording and detailed EPG info (for North America)?

Thanks.

Hi

sudo apt-get remove xmltv and crontab -e and removing your cron line should do the trick.

Are you using an ATSC tuner? I think this should grab EPG data over the air, but can be slow to populate

Sam

Hi,

I think it will be sufficient to do this:

cd ~/xmltv/ 
rm *
cd ..
rmdir xmltv

sudo su - hts
rm .xmltv

In TVHeadend, clear the schedule for “Update Channel Number”

Remove “mm hh * * * /home/[user]/xmltv/zap2xml.sh >/dev/null 2>&1” from crontab using crontab -e.

At this point I would reboot.

It looks like zap2it.com is down, hopefully its a temporary. Heres a good guide for/if when it comes back up:

Thanks Tom.

Hi Sam,

I tried sudo apt-get remove xmltv and it says it is not installed, so not removed

I’ll try Tom’s suggestion next, however, after my attempt to remove xmltv, it says:

The following packages were automatically installed and are no longer required:
_big list of things_
Use sudo apt autoremove to remove them

Is this safe to do?

And yes, I am using an ATSC Tuner (HDHomeRun Duo)

Have you tried this @Tom_Doyle?

It seems similar (but not identical) to the process I went through before and it hasn’t been updated in a while.

FYI zap2it.com seems to be up and running again.

HI,

Probably, but we need to see the “big list of thing” to be sure; I would paste here:

https://paste.osmc.tv/

And provide the link.

Looks like post 7 has the most up to date instructions:

Looks like its just down for me…

Thanks Tom.

One “big list of things” coming up…

https://paste.osmc.tv/disosawalu.vhdl

Hi,

I may be wrong but that doesn’t look right to me, @sam_nazarko any thoughts?

in the mean time could you please issue the following command:

grab-logs -a

and post the link here.

Thanks Tom.

Here you go

https://paste.osmc.tv/vukudiyude

It looks OK. You can run sudo apt-get autoremove to get rid of those packages.

My guess is you’ve had Vero for while and updated from Jessie to Stretch in January this year. So these are just old packages.

Sam

1 Like

Looks like post 7 has the most up to date instructions:
[Obsolete] How to populate EPG data with zap2xml - #7 by wbeard52

I don’t understand how to install this. According to the readme…

  1. Install the zap2epg addon in Kodi
  2. Run the addon and setup your lineup
  3. Configure your channel list (add channels to be downloaded)
  4. You can run the program from the addon as a test - not necessary
  5. Setup the zap2epg grabber in tvheadend
  6. Enjoy your new EPG!

I’m sure instruction 1 is to manually copy some or all of the files to my Vero using Putty or WinSCP, but I don’t know where to put them. If I go to my TV and look at available addons from within Kodi (not remotely through an terminal emulator) , there is no zap2*anything* to install.

This is what is in the zap2epg zip file:

sshot-1

Hi,

in Kodi go to settings, Add-on browser, Install from zip file

Easiest way would be probably to copy the zap2epg zip file to usb stick.

Thanks Tom.

@Tom_Doyle When I try and follow the instructions and ...copy the tv_grab_zap2epg to the /usr/bin folder WinSCP gives me this error:

sshot-2

1 Like

Hi,

Not familiar with winscp my self. If it was me I would I would use the command line:

https://osmc.tv/wiki/general/accessing-the-command-line/

I would do the following:

cd ~

wget https://github.com/edit4ever/script.module.zap2xml/releases/download/v0.7.5/script.module.zap2xml-0.7.5.zip

unzip script.module.zap2xml-0.7.5.zip

sudo cp script.module.zap2xml/bin/tv_grab_zap2xml /usr/bin

sudo chmod 755 /usr/bin/tv_grab_zap2xml

Thanks Tom.

But according to [Obsolete] How to populate EPG data with zap2xml - #7 by wbeard52 I should be using zap2epg. So, using the info you gave me above, I’m guessing I should instead type:

cd ~

wget https://github.com/edit4ever/script.module.zap2epg/releases/download/v1.0.0/script.module.zap2epg-1.0.0.zip

unzip script.module.zap2epg-1.0.0.zip

sudo cp script.module.zap2epg/bin/tv_grab_zap2epg /usr/bin

sudo chmod 755 /usr/bin/tv_grab_zap2epg

Hi,

Sorry, yes you are correct.

Thanks Tom.

Well, the install instructions seem to have worked, but I’m not sure it’s working.

The EPG seems rather sparse and not as full featured in description as I would have expected.

In TVHeadend, under Configuration → Channel/EPG → Channels, I see plenty of channels listed

and the EPG source column has plenty of references to zap2epg, so I guess it worked.

If anyone knows of a simple and straightforward tutorial on properly setting up the current version of TVHeadend, I’d appreciate it. There are plenty of settings that I have no clue what they do and I bet the answer lies somewhere in there.

Hi,

This may help:

Thanks Tom.