Horrible wireless mouse lag after first OSMC install on raspberry pi 3

Hi there, I am a completely new user in this area. I just bought, installed and started up a raspberry pi 3 with the OSMC system. Now all seemed to go ok, but I have horrible input lag when i try to do anything. There is a slight delay on the keyboard (wired) and mouse is prectically unusable (wireless).

Any help on how to fix this? Sorry if this is a duplicate, but i searched and didnt find a case quite like mine on this forum.

Thank you.

EDIT: What we figured out so far:
Mouse works on other PCs
Wired mouse works ok on the Raspberry

logs: https://paste.osmc.tv/noxejepeqa

Well I think you should define “slight delay” clearly the Pi3 is not a power monster and the Kodi GUI is quite demanding. So it might feel a bit sluggish for new users.
With the mouse that is a different topic. The mouse movement itself shouldn’t be to sluggish.
Maybe provide logs either via MyOSMC or command line grab-logs -A so that we can advice

On first installation, when adding medias, the kodi software will analyze and scrap data.
Let it put for a couple of hours (depending on the size of your media-archive) and it should be good.

I have restarted it and unplugged any storage devices so that right now only the mouse and keyboard are connected… didnt get fixed.

Also I notice that there is a lightning bolt icon on the top right, although i dont know why, as I use a 5V 2.1A power supply.

Is it an official Pi power supply or “just” a phone charger?
Phone Charger are not designed to power the Pi and may not give enough power.
This actually also could be the problem why the USB device has problems. So I suggest you get a proper powersupply
Neverless let us take a look at the logs maybe we see something else.

here are the logs


The keyboard lag disappeared with the restart, mouse is still lagging.

As for the PSU, it is a “power socket => USB” kind of thing with identical specs to the official PSU, so it shouldn’t be a problem. And according to internet, 2 amps, should be more than enough to run raspberry.

EDIT: it’s actually 3 Amps apparently

AFAIK official PSU for Raspberry 3 is +5.1V 2.5A

Anything jump out at you in the logs, fziken? Or is it just a hardware issue?

Nothing jumps out. But the power supply still might be the culprit. It’s not only about the Amps but also the stable Volts above 5V.

Lightning bolt disappeared when i replaced the cable. Right now i don’t have power issues, but the mouse is still too slow.

OK i just tried a wired mouse and that works OK, so it’s gotta be the wireless that is the issue. I tried the wireless mouse on another PC and it’s fine.