How can I customize the OSMC skin to my needs?

As the default font size of the OSMC skin is too small for my screen, I tried to increase it to my needs. I found all the neccessary files in the skin’s folder and my changes worked like intended.

However, one day later, the whole skin got reverted to default settings. I suppose this is due to OSMC updates or file integrity checks.

Therefore I’d like to know what’s the recommended way to keep these changes permanently. Do I have to make a clone of the OSMC skin and edit this copy? If so, how? If not, what other options do I have?

Copy the folder, name it something else, edit the addon.xml.

Thanks. I copied the whole /usr/share/kodi/addons/skin.osmc directory to /usr/share/kodi/addons/skin.osmccustom, edited the addon.xml (id=“skin.osmccustom”, name=“OSMC Custom”) and changed the font sizes in /16x9/Fonts.xml

The new skin loads fine with the new font sizes.
However, everytime I switch to the main menu the GUI stops responding for two seconds and I get this error message:

Menü kann nicht erstellt werden. (Can’t create the menu.)

Regardless, the main menu is showing correctly, and I can use OSMC as usually after I dismissed the message. Is there anything else I have to change?

Move it to /home/osmc/.kodi/addons

Sorry, I hadn’t access to the device for last three weeks and couldn’t solve this earlier.
I moved the folder to /home/osmc/.kodi/addons as recommended, but the problem still persists.

After I switch to the main menu, the menu itself is showing fine. After ~5 seconds I get some toast messages on the bottom right corner, something like ‘Creating menu’ or ‘Creating shortcuts’. A second later, the error message I described above is displayed.

I’ve uploaded all debug logs to
Is there anything else I can do? Please tell me if I can provide more important information.

After skimming the log, I came across this line:
16:54:48 134.559647 T:1520432112 ERROR: IOError: [Errno 13] Permission denied: u’/home/osmc/.kodi/addons/skin.osmccustom/16x9/script-skinshortcuts-includes.xml’
Maybe this is linked to the error message? Should I modify permissions to this file only or to the whole skin folder? What permissions settings should I apply?

I noticed that the custom skin folder’s owner was root instead of osmc.
After changing owner and group of the whole folder, everything is working now fine.
sudo chown osmc ~/.kodi/addons/skin.osmccustom -R
sudo chgrp osmc ~/.kodi/addons/skin.osmccustom -R

Since I’m not a Linux low level crack like other ones, may I ask you why the owner for the osmc skin folder has to be set to osmc, while the confluence skin is working with the owner set to root?