How can I enable the Yatse remote interface?

I have moved my OSMC media player back from our vacation home, but I forgot to bring the remote control…
So I thought that I could revert back to the Yatse remote app on my Android phone until I could get the remote back home. I used that a while until I tired of its limitations and hooked up a proper remote instead.

But for some reason Yatse stays inactive (no action on Yatse registers with Kodi) so I cannot interact with the OSMC Kodi.
I have checked that the Yatse remote app is set to the correct IP address of the Ethernet port on the Raspberry Pi and I have checked that I can reach the OSMC Pi with PuTTY using this address too. The login is osmc/**** and Yatse does not say it is off-line either.

Is there any way to configure the Kodi system on OSMC via SSH (PuTTY) or using the website at port #80 from my PC so that the network remote channel for Yatse opens up? I can bring up a OSMC web screen by going to the http port of OSMC in Firefox (login required). But what to do here is beyond me…

I also connected a USB mouse to the Pi and then I could make Kodi go out of standby (greyed out home screen), but navigating to something using the mouse is clumsy and I just discovered that there is no way back once I had drilled down from VIDEOS to the selection between files, lists and add-ons. So now Kodi seems stuck there with the mouse only able to go down and not up.
What can I do to make it work with Yatse?

Well if you can reach the website than Yatse should also see your OSMC as it is using (for it’s basic communication the same interface).
Also if you can reach the webinterface from your PC you can use the remote controll of the webinterface to navigate.

It seems like Yatse connects to the OSMC because before I entered the login data into its configuration it said it was off-line, not so anymore.
But no matter what button I press in the Yatse app nothing at all happens on Kodi…

[quote]Also if you can reach the webinterface from your PC you can use the remote controll of the webinterface to navigate.
I do not know what remote in web interface you mention…
Could you elaborate a bit? I get a very basic black screen on FireFox but no way to interact like with a remote control.
If there was a way to post images here I could supply a screenshot…

Than you must have either change something or you are connecting to something else than the Kodi Webinterface. How the default webinterface looks like you can see in this post

Maybe post the output of cat .kodi/userdata/guisettings.xml | grep web

osmc@osmc:~/.kodi/userdata$ cat guisettings.xml | grep web
        <webserver default="true">true</webserver>

I have now succeeded in starting a video located on my NAS from the web interface (but the local drive where all of the material is supposed to be played from was invisible).
When the video is on screen on the RPi HDMI device I can use Yatse to pause, restart and stop playback. These buttons seem to work. But no other buttons still work!
I cannot navigate anything at all! All arrow and home and other navigation buttons do exactly nothing both when the video is playing and when the OSMC Pi is idle just showing the main menu.
So this is why I thought Yatse was completely disconnected. Now I see that only these few buttons are active on Yatse, which is really not useful.
I did update my Yatse app to the latest version and I updated OSMC about a month ago to the latest version too.
Is there a filter on the web interface which controls which codes are let trough to Kodi?

Seems you changed the webinterface and also the port. Not sure if both of it was on purpose. Default should look like

osmc@osmc:~$ cat .kodi/userdata/guisettings.xml | grep web
        <webserver default="true">true</webserver>
        <webserverport default="true">8080</webserverport>
        <webskin default="true">webinterface.default</webskin>

You can leave the port on 80 if you want. But suggest to change the webinterface to default to avoid issues.

Also ensure that you have these three settings on true
<services> <esallinterfaces>true</esallinterfaces> <webserver>true</webserver> <zeroconf>true</zeroconf> </services>

If all to no avail than go the vnc path

I don’t think I have edited this file ever…
When I use my Win7 PC and FireFox to go to http://osmc the web interface (AWX) starts but it shows a number of messages to the right saying:
“Attempting to connect to websocket”
“Failed to connect to websocket, retrying”
These repeat about 4-5 times and then go away.

It does not say which websocket it is trying to access…

If I then click the top second leftmost icon a dropdown list shows up and I can select “Files”
Then only the following is shown:
Addons (unsupported feature)

Notice that the main local drive MEDIADRIVE is missing from the list. It contains the bulk of my files…

stupid question but have you added your media drive as a source?

In files, localdrive shows without makeing a source of them, they wont show in web interface unless they have been added as a source. I had that problem.

Well you don’t need to have edited that file but obviously you most likely via the GUI changed to the AWX webinterface. So why not change back to make your testing.

1 Like

Settings>Services>Web Interface>click on reset to default then reboot. You can go back with your mouse by right clicking on a blank/inactive part of the screen. There is also a “Home” button at the bottom right corner of the screen (using Confluence skin, not sure about the OSMC skin) you may need to enable mouse/touchscreen support in Settings>System>Input Devices to make the button show.

Just to clarify choosing reset in the web interface screen will only reset that page of settings to default, NOT the complete system.

[quote=“joakim_s, post:8, topic:19090, full:true”]
stupid question but have you added your media drive as a source?
[/quote]No, it showed up anyway…[quote]
In files, localdrive shows without makeing a source of them, they wont show in web interface unless they have been added as a source. I had that problem.
[/quote]Interesting, so if I add it then it will show up…
Now that my main problem is that I cannot reach the KODI screen with my remote (because it is in the vacation home) and Yatse does not work, how can I add the /media/MEDIADRIVE/VIDEOS/ as a source? I have looked over everything I can think of in the AWX web interface but found nothing obvious…

Going back to the web interface remote, I suddenly saw that a white blob in the lower right corner looked strange and on closer inspection it is a button enabling a webpage remote control!
So my earlier complaint about not finding the webpage remote is now solved.

I found a config file named sources.xml, I edited it in the hope that MEDIADRIVE sould show up:

        <default pathversion="1"></default>
            <path pathversion="1">smb://NAS/VIDEO/</path>

The second source node is my addition.
However it did not make any difference in the web interface, no MEDIADRIVE…

Try changing <path> to <path pathversion="1"> I’m not sure it will make a difference but give it a try.

Edit: I’m ASSuming that you rebooted after editing sources.xml if not then start there.

Thank you very much for this suggestion!
Since I could not find out how to add the drive in the web interface I managed to use the mouse for navigation into the position where the source could be added. And lo-and-behold! It worked!
Now the local drive shows up in the web interface too under the Video/Files section.
Thanks again!
One problem ticked away! :slight_smile:

Thanks for the suggestion!
As I just wrote I managed to get to the source setup in the KODI GUI using the mouse (hard but possible). After I was done there the disk appeared both in the Kodi GUI and in the web interface. Then I looked again at the sources file and now the code was changed to:

            <path pathversion="1">/media/MEDIADRIVE/</path>

So you are absolutely right about the property pathversion!
Since it was now done via the KODI GUI no reboot was needed, instead it scanned the new source for videos, don’t know what good that did but still it is now working.

Yatse is still inoperative, though.

I guess I will give up for now and drive out to retrieve the remote beginning next week…

@Bosse_B, this is how i got yatse to work:

in webinterface:

got to your cogwheel (top right)
click “Kodi Settings”
click “Services”
click “Web server”
Click on the bottom input box, choose default.webinterface
Click “General”
Click “Save” bottom right.

That should make your yatse working again( if not try to remove and readd your kodi device)

This will render your webinterface useless untill you, via kodi, choose another 3rd party webskin (i choose chorus).
Then Reset to defualt settings.(just restting to default settings didn’t work for me, there for i went with a third web-skin)

Voila got both web-access and yatse,

Did you try resetting the Web Server settings as suggested above?

Thanks for the final solution!
I did all of the above, including removing the Yatse Host and re-adding it afterwards.
Did not change skin in OSMC Kodi and I just refreshed the web page to see it change to a more conservative view. No restart needed…
This made it into the finish line!
Now working with Yatse as I was used to before.
Many thanks again for your valuable help!

Resetting the web interface made it not so useful anymore since the Video/Files node is not visible and this is where I keep ALL of my videos.
But I was not after a working web interface but a working Yatse one and this is now OK.