How can I nail down erratic DVD-drive non-startup issues?

Hi all.

I have bought a few Vero2 units for mounting in a car as an infotainment system and I’m facing some annoying issues with 2 out of 2 different external DVD drives that I connected with USB to the Vero2. We need a cable about 2 meters long and during tests on my bench it worked even though we mistreated the (test) box, such as cutting off the power while the system runs… the DVD drive always worked.

Now we’re connecting new DVD drives of the same brand to a new Vero2 unit and there’s no playing a DVD. Even worse, sometimes Kodi plays the disk and sometimes it doesn’t. Kodi seems to detect the disc since the menu command “Play disc” appears between the System and Programs menus (Confluence skin activated). If I take the same DVD drive and test it on my laptop, no problem, I can play the video. But then there’s no OSMC on my Laptop as it’s installed with Manjaro.

The problem is I don’t know whether I should incriminate the cable length, a faulty supply voltage on behalf of the Vero 2 or a bug somewhere, you name it… I previously used a DVD drive from the USA (made in China though) that had a dedicated DC power jack, this one has none so I conclude it is designed to work properly, powered from its own USB connection. The drive is an LG slim portable drive model GP70NS50.

I can’t seem to tackle the problem own. Any hint is welcome.

Thanks a lot in advance.

Use a powered USB hub.

Well, I have none, alas :frowning: . Isn’t there any other way to nail down the issue from Kodi itself? I’m a 12-years dedicated Linux administrator and I’m happy with a console screen and a syslog journal. Is there such a feature accessible on the Vero2?

The most likely cause is that the Vero device is not able to consistently provide sufficient power to the DVD drive.

Also, that ninja edit of your OP makes the insufficient power diagnosis no less relevant and no more a Vero 2 hardware or software fault as it would seem you are attempting to indicate.

This drive worked without an issue right?

Other problem is what you call a “ninja update” is about something I should never have mentioned in the first place since not really relevant. Typing mistake and I was doing several things at the same time, pissed off because of other problems arising in the same time window… well, “overwhelmed” is not too strong a word. So sorry for the disturbance.

No, it didn’t work. It worked with short cables, for instance but not with longer ones. Or it did work, didn’t, did, didn’t… randomly failing so we changed the hardware. Not for any better symptoms.

Cable length can certainly be an issue.

I do agree. But then what is but self-explaining is why it did with one of my own cables, which I trust as if it were my own ass, stopped working all of a sudden…

That said, I’ve just seen something strange on the Vero2 box: I inserted a disk in the drive with a brand new, long USB cable (read 2m), properly shielded I believe for I trust the supplier I got it from and when I press “Play disc” I still get nothing. However when I go through the «Video» menu, then «Files», I can see the title of my DVD. Just that when I click it, I suddenly browse the root file system! Meh? What the…?

So I’m doing updates right now and will see…

EDIT: No change even after updates.

You need to consider that your laptop also has a greater ability to provide more amperage than the Vero2. When the demand for amperage exceeds a devices ability to provide it, voltage begins to drop and results in erratic behavior if not a complete failure to function.

I was afraid of that :frowning: . Is there any way to increase the limit of the Vero2 current limit like there is on the Raspberry Pi (IIRC)?


Well, crap.

By the way, what’s that (hardwired, I guess) limit? The idea behind is to assert the consumption on a regular laptop and see how much higher it is than Vero2’s limit.

We provide 0.5A per USB port, which is the usual standard. I believe that a laptop would provide the same output, unless something like ‘Fast Charging’ was enabled in the BIOS.

I can understand that this issue may be tricky to investigate. Can you explain whether you are playing encrypted or decrypted discs?

Try and check dmesg with a disc that works and a disc that doesn’t.

Thanks Sam. So far the DVD drive works on all the computers which we have tested it with. This means if this is a power supply issue, then all computers do provide more power than what the strict standard recommendation, which comes with no surprise to me. I’m not sure the discs are encrypted, all I can say is it doesn’t matter because the same disc plays or doesn’t play depending on what cables and drives I test it with. In short the discs I’ve used have all been played at least once in certain circumstances, which rules out an eventual cryptography problem, unless I’ve missed your point.

However I’ve finally found a drive that works even with my 5m Belkin USB Pro cable, which no drive has ever come to successfully play with. It comes with an external DC power jack, is fabricated by LG specifically for Mercedes and is included in a service kit for garages and maintainers. Not the cheapest solution but that works a treat. We’re looking by our suppliers if we can buy it separately.