How do I get music visualisations?

I’ve just set up a music library on my OSMC setup. There are no visualisations. I note there was a thread from late 2019 asking about them, but with no conclusive result.

I’ve tried installing the Kodi binary repo from GitHub - xbmc/repo-binary-addons at Leia but it fails as apparently this might be a Git repo but it’s not formatted as a Kodi repo.

So how do I get music visualisations on OSMC? Bonus points if I can do it entirely with the remote, without having to go upstairs and download things and copy them across :slight_smile:

(Seriously, these just installed on earlier versions of Kodi. Why did the devs take Leia and say “I know, let’s make it harder for people to do things”? How could “it’s now harder to do this” be anything other than a release blocker?)

This is still a work in progress, but for now I think you can install the ShaderToy add-ons.


Okies I’ve read some forum posts about doing this via Shadertoy and to be honest the result I’ve gotten so far is a) they don’t work regardless of which skin you use (an old thread said changing that might make a difference) and b) It’s causing Kodi to crash intermittently with the sadface icon, which is odd because it’s only been up on a fresh build since Saturday.

Any ideas? Ideally I’d like some basic visualisations and Kodi not to crash… :joy:

EDIT: Oh I think I just worked out what the crash is caused by. Changing skin when music is playing.

Visualisations should make a re-appearance with Kodi v19 which is in the late stages of release.

That’s great! Thanks Sam. So does that mean there’s no way to hack Shadertoy support onto the Leia version for now? Wasn’t able to find conclusive information on whether or not support for those being broken was version related.

You could try the version from the @popcornmix repository.

If you have no such luck, I think it’s best waiting for v19. I won’t be doing any more work on Kodi v18.9 given that this is the last version to be released, and Kodi v19 support really isn’t that far off.



If you want to try out ShaderToy with Kodi v18, kodirepo/zips/visualization.shadertoy at master · virserg/kodirepo · GitHub seems to provide the best results for me. Unfortunately, there is no source code - or at least I cannot find it.
The version from popconmix repo didn’t work for me which is a bit unfortune as a lot of improvements went in there. But some of it also went into the rework for Kodi v19 - I think.
It is also possible to compile shadetoy from GitHub - xbmc/visualization.shadertoy: Shadertoy visualizer for Kodi using the Leia branch but that is a bit more involved and gives worse results as the binary referenced above.

Do you mean the one found in this link?

If so that’s the one I’ve referred to that doesn’t work on my Vero 4K.

I’m curious to know what might have changed in Kodi versions that would break a plugin that itself hasn’t changed much in years even if just for my own edification. I figured someone might have a “quick and dirty” solution to enable it, but having spent many hours in the last few weeks upgrading/tinkering with my home media centre setup I’m kinda out of steam.

This has been discussed so many times: Easter update - music visualization not working any more - #10 by virserg

Just follow from the link, a bit more down in that thread I explained some of the settings.

Quick and dirty (well for end users) solution enabled!

Well played sir! From zero visualisations to 33, not bad at all. Thank you. I actually like some of the Shadertoy ones more than the more common ProjectM ones.

1 Like

I built goom for the vero.

Thanks bud! I have this installed now.

My my, what a helpful community! Impressed actually.

So, now that Kodi 19 is here, what’s the recommended way of getting visualisations for it?

ISTR reading that there would be a Matrix-themed one included in OSMC, but it’s not showing up on my Vero 4K+ at all…

They are preinstalled but disabled. If you go to add-ons>my add-ons>look and feel>visualization> then you should see a bunch of them showing as disabled. Click on one you want to use to bring up the information window for it and then click on the “enable” button. Rinse and repeat.

1 Like

Argh — I looked everywhere except the list of what was already installed! Thanks!

Should be nice once I can persuade the Jellyfin plugin to actually play the audio files…

1 Like

Is the shadertoy visualization (not the screensaver) now part of Kodi 19.1 Matrix?

I had it previously installed from a zip in Leia and it worked there. Now I have a version that says 2.3.0, installed Oct '20 and I cannot uninstall it. It crashed when I first tried to run it after updating OSMC to Kodi 19.1. Then I removed visualization.shadertoy from addons and corresponding user-data as well. It appears to run now but it seems the sound is not attached to an iChannel and all those settings are grayed out. This is on RPi2.

Yes it is included.

Ok, thanks. Can I still replace that with another version now that it is built in? I guess I need to dig into it and try to recompile to see what’s going on with the sound unless someone else has an idea why it does not react to sound. Basically, I have an idea but I’m not sure if that’s only on my system or on RPi2 in general. When I tried last, I had to replace red with the luminance channel in the code to get it to work correctly. Don’t have an RPi3 or RPi4 to test with.

You can use your own version indeed, but you’d need to build it for OSMC.

Got it compiled and working again with audio using the steps (adapted to Matrix) that previously also worked for Leia when using the “offical” shadertoy visualization Where did ShaderToy go? - #12 by Panisher