How do I get write access to the USB-drive?


I received my Vero4K yesterday - quite an upgrade from the trusty WDTV Live that I had been using since 2009. :slight_smile:

I keep all my media on a 4TB NTFS drive connected to the Vero. I need this drive accessible from the network to upload new content and delete / rename / move what is already on there. The WDTV did this by default (exposing the filesystem to the LAN over samba).

I’ve been reading and playing around for a day but I’m only halfway there - I have read access to the filesystem, but no write access. I’d really appreciate some advice, thanks!

  1. My windows machine automatically detect the default “network location” for the Vero4k - a “media device” named osmc which exposes two folders - Music Library and Movie Library. These have no direct relation to the filesystem so they are useless for my purposes.

  2. I can use the windows file explorer to navigate straight to the hard-drive; \\Maxtor using the default username / password. It does indeed let me browse the filesystem properly, but I have no write permissions. No renaming, moving or uploading possible.

  3. I have activated the SSH-service and tried via SFTP. The drive is accessible via /media/Maxtor but despite all folders and files being owned by the osmc user, they remain read-only.

So… what do I have to do, for the Vero to share the USB-drive with the LAN for anyone to add files to it?


The disk automatically should be read/write. Which Filesystem are you using? Can you post ls -lah /media

The disk is NTFS (edited the first post to add that info).

osmc@osmc:~$ ls -lah /media
total 16K
drwxr-xr-x  3 root root 4.0K Jan 23 02:41 .
drwxr-xr-x 23 root root 4.0K Jan 22 17:16 ..
drwxrwxrwx  1 osmc osmc 4.0K Jan 19 22:56 Maxtor
-rw-r--r--  1 root root  232 Nov 21 20:36 README

The Maxtor folder is highlighted bright green (which, as far as I know, means it should be other-writeable?)

Content of the drive:

osmc@osmc:/media/Maxtor$ ls -la
total 116
drwxrwxrwx 1 osmc osmc     0 Jan 18 16:08 $RECYCLE.BIN
drwxrwxrwx 1 osmc osmc  4096 Jan 19 22:56 .
drwxr-xr-x 3 root root  4096 Jan 23 02:41 ..
drwxrwxrwx 1 osmc osmc  4096 Jan 22 22:31 DVD
drwxrwxrwx 1 osmc osmc  4096 Jan 22 22:08 Documentary
drwxrwxrwx 1 osmc osmc  4096 Jan 22 22:15 Live Music
drwxrwxrwx 1 osmc osmc  4096 Jan 22 22:21 Stand-Up
drwxrwxrwx 1 osmc osmc     0 Jan 19 13:55 System Volume Information
drwxrwxrwx 1 osmc osmc 12288 Jan 22 22:36 TV
drwxrwxrwx 1 osmc osmc 81920 Jan 22 23:51 Video

Then lets first try if it is writeable from command line
touch /media/Maxtor/TV/test-file
ls -lah /media/Maxtor/TV/test-file

Denied. The drive is mounted as read only it seems.

osmc@osmc:/media/Maxtor$ touch test
touch: cannot touch 'test': Read-only file system

I guess it was uncleaned when you mounted it.
Try sudo umount /media/Maxtor disconnect and reconnect
Also check dmesg afterwards and mount

So, I did umount and then physically disconnected and re-connected the drive, followed by dmesg:

[ 1617.424233] usb 1-1: new high-speed USB device number 4 using xhci-hcd
[ 1617.565631] usb 1-1: New USB device found, idVendor=0bc2, idProduct=61b7
[ 1617.565643] usb 1-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ 1617.565649] usb 1-1: Product: M3 Portable
[ 1617.565653] usb 1-1: Manufacturer: Seagate
[ 1617.565658] usb 1-1: SerialNumber: NM14C12V
[ 1617.567333] usb-storage 1-1:1.0: USB Mass Storage device detected
[ 1617.567854] scsi1 : usb-storage 1-1:1.0
[ 1618.564806] scsi 1:0:0:0: Direct-Access     Seagate  M3 Portable      9300 PQ: 0 ANSI: 6
[ 1618.567709] sd 1:0:0:0: [sdb] Spinning up disk...
[ 1619.574139] ......ready
[ 1624.624955] sd 1:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[ 1624.625374] sd 1:0:0:0: [sdb] 7814037167 512-byte logical blocks: (4.00 TB/3.63 TiB)
[ 1624.637457] sd 1:0:0:0: [sdb] Write Protect is off
[ 1624.637488] sd 1:0:0:0: [sdb] Mode Sense: 4f 00 00 00
[ 1624.638053] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 1624.640648] sd 1:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[ 1624.734562]  sdb: sdb1 sdb2
[ 1624.736457] sd 1:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[ 1624.737625] sd 1:0:0:0: [sdb] Attached SCSI disk

Tried creating a new file on /media/Maxtor - still write protected.

Ran mount, tried creating new file, still write protected.

I’m flailing here - what are we trying to do?

Ok that dmesg snipped is not good enough. Share URL of grab-logs -J -K

Holy crap what an amazing utility! Someone really though ahead with this one. :smiley:

(also: I tried rebooting the Vero4K to make sure it wasn’t waiting to apply some settings somewhere)

For me it looks like the the drives reports itself read-only. I totally out of an idea why that i happening so I call for the guru @DBMandrake

Jan 23 15:09:19 osmc ntfs-3g[738]: Version 2016.2.22AR.1 integrated FUSE 28
Jan 23 15:09:19 osmc ntfs-3g[738]: Mounted /dev/sda2 (Read-Only, label "Maxtor", NTFS 3.1)
Jan 23 15:09:19 osmc ntfs-3g[738]: Cmdline options: rw,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177,fmask=0111,dmask=0000,uhelper=udisks
Jan 23 15:09:19 osmc ntfs-3g[738]: Mount options: rw,nodev,nosuid,uhelper=udisks,allow_other,nonempty,relatime,ro,default_permissions,fsname=/dev/sda2,blkdev,blksize=4096

Solved! Turning off write-caching in windows seem to have made the drive well-behaved on the Vero.


Thanks a ton for helping out!

1 Like

That sounds logic. While I would have assumed that the umount command should have cleaned it but may have needed to run chkdsk. Great that you solved it.

Who’dve thought that setting was stored in the drive itself, not in the operating system.

I doubt it is a flag being stored on the drive. I just believe it is more the unclean removal of the drive which let it be in that status