How do I mount Windows network shares in OSMC?

New user here and total noob on the OSMC platform.

Had a Raspberry Pi with XBMC, it worked great. Until it stopped working :smile:

Now I have a Raspberry Pi B+ with OSMC. I’m trying to add Windows network shares that used to work in XBMC but whenever I select Browse>Network File system (NFS) in OSMC it thinks for a second or two and then nothing.

Explain it to me as if I were a five year old - how do I add allready shared folders from a network connected Windows 7x64 computer? I have tried the Raspberry both on cable and wifi but still the same. In XBMC I could just browse through all the units on the network.

The Windows share is rachable from several other devices such as my Xbox, Flex media player on iPad, my Smart TV, other PCs on the network (both wired and wifi) etc. so the share works just fine.

Sorry if this is a stupid question. I tried to search the forums and google it but I just ended up with like a millon files needing editing and thought it should be as easy in OSMC as in XBMC.

Sorry if this is a stupid ‘answer’, but is it NFS rather than the windows default of SMB? Searching for an NFS share would give no result if you just did a standard Windows share.
If it really is NFS, then try adding the path manually.
BTW the topic says mount - is that what you are really wanting to do, rather than just set of a source path (which is what you queried).

1 Like

That was a great answer :slight_smile: NFS is the only option given in the Video Browse section of OSMC, but I guess SMB is what I was really after. And by mount I mean… Well I don’t know what I mean, I just wrote it due to so many people using the word on the internetz and these forums :slight_smile: You are correct, I just want to set a source path to my network share and hopefully the OSMC device will remember it after reboot :smile:

I’ll try to type in the source path manually, and if it works (and f it was that easy) I’ll go hide in the closet and feel really really dumb :stuck_out_tongue:

In the add source dialogue choose add network location, then you can add any protocol type such as SMB.

To expose the smb browse option, you may need to change the setting in System|Settings|System to Advanced or Expert

To browse smb sources, you need to get smb service from the osmc store. On the osmc screen, it’s the shopping cart. When you browse smb, the first thing you see is WORKGROUP, the Windows Network Sharing you set up in the Control panel. If you double click WORKGROUP, you get a choice of every device on the network, hopefully including the PC you want to share. Double click the PC, and you can drill down to the file you want. If you don’t see a folder, you may have to use Windows Explorer. Right click on the folder>Properties>Sharing to allow Windows to share the folder. You can Google more info on how to set up the Windows side.

1 Like

The smb package in the app store is only necessary for sharing devices (even the pi OS locations) connected to the Pi to the local LAN by smb. Browsing and using smb sources from other devices by use of Kodi does not require this addon.

Hi! I have a Windows 10 PC with a share:
This share has permissions set to let Everyone access it.

Noobie question:
What do I type to add this share to the OSMC system?

I’ve tried the slashes both ways - / or .
I’ve tried putting smb://192.168.x.x/filestorage.
I’ve tried adding a slash at the end.

Thanks for any and all help!!


I guess you can find some answers here

1 Like

I have spent close to six hours trying to get the Pi3B+ (or OSMC) to see the directories on the network. The network (router) sees OSMC. OSMC sees the network (in the wireless status menu) - but that’s where it ends…

Windows 10 Pro. I have cleared and checked all the file sharing options. Nothing. Everything worked when I had a Pi0 and Windows 8.

Ready to throw the whole lot away. Any suggestions? Assistance will be greatly appreciated. Gavin

Are you trying to browse shares?
If so: did you select SMBv1 in Kodi?


More information would be helpful. Can you ssh into the Pi? Can you ping the Pi? Have you tried to mount the shares via fstab? Are you getting errors?