How dvb t2 dongle works?

Hi ,
I’m interested in this OSMC dongle but I cannot figure out how it works.

Sorry for the dumb questions, but they will help me to understand:

  1. It should be connected to an external antenna?
  2. I’ve read that it use TVHeadend server to work: it is need to continuously streaming or just to update the EPG?

I currently live in south of France, my internet connection is very slow (2bm/s) so I cannot see TV in streaming.

Thanks for any help.

  1. Yes – you need an aerial.
  2. TVHeadend is used to watch, record and update channel information. It can be installed from the OSMC App Store.


I think that France DVB-T is now DVB-T2 with a lot of channels in HD so might there be a problem with the official dongle - perhaps depending on Vero or RPi?

@farnis: what device are you using?

If it’s Pi, DVB-T2 will be fine
If Vero 4K: only DVB-T will work for now. This is being worked on however. See [TESTING] DVB improvements for Vero 4K.


Hi @sam_nazarko,
I’m using a Rpi and bought the DVB-T2 on the OSMC shop.

I’m waiting the dongle, I’ll let you know my feedback and come back if I have any further questions :slight_smile:

Hi @sam_nazarko
I’ve got the tv dongle and I think that I install it correctly. My doubt is that the aerial doesn’t provide the signal.
Do you have any suggestions about an external antenna that I can pair with the dongle?

A roof one is best if possible. But I don’t have a recommended antenna.

Hi @sam_nazarko,
got a technician visit and the antenna is working now. Only issue I have is that I cannot make the dongle work.
Is there a way to reset TVheadend server so I can start the configuration again?

I got this error:

2018-03-23 12:18:15.386 htsp: Welcomed client software: Kodi Media Center (HTSPv25)
2018-03-23 12:18:15.388 htsp: [ Kodi Media Center ]: Unauthorized access
2018-03-23 12:18:20.389 htsp: [ Kodi Media Center ]: Disconnected


To reset the config:

Thanks Tom.

Thanks. I’ve reset the configuration.
I can see the TV on my iPhone (with TVhClient) but not on OSMC.
So I guess that the aerial and the dongle are working now, but there are some problems with OSMC Live TV. Don’t have time right now to debug the logs, I’ll keep you posted.

Edit: here the logs if anyone can help! Thanks

What are the problems?

When select Live TV on the OSMC UI I can’t get the guides, the channels etc.

I created 2 users on the TVHeadend server but I cannot understand how to configure OSMC client to access the server.

On the iPhone I configured the server, the port, the user etc but on OSMC there is nothing similar.


You need to set the username & password in the TVHeadend HTSP Client, more details can be found here:

Thanks Tom.

Thanks Tom,
that is what I did.

In the last step I tried with both and my local IP ( but still get the notification error that the client is not able to access the server.

UPDATE 1: I just restarted the Raspberry and now automagically everything is working really well.
The quality is amazing!

UPDATE 2: not sure if it related but if I try to reboot or shutdown OSMC I got this screen and have to manually unplug the power.