How to access advancedsettings.xml

I’m having buffering issues through my wired connection with a specific 4K movie:

I’d like to try to increase buffer size in the advancedsettings.xml but I can’t figure out how to access it. I want to connect to it from my windows desktop and know the IP of my Vero but that’s about it.

The advancedsettings.xml file can be found in /home/osmc/.kodi/userdata, though it might need to be created if not already there. However, increasing the cache size might not be an answer to your buffering problem. Here’s why.

The video bit rate is around 90 Mbits/sec and the audio bit rate is a little under 4 Mbits/sec. In total, the average bit rate is going to be just under 94 Mbits/sec.

On a 100 Mbit/sec ethernet connection, iperf3 will usually show somewhere around 93-94 Mbits/sec. Add an overhead for the filesharing protocol, eg NFS using fstab, and your network interface will probably be at – or beyond – its limits with this video file. This is why you’re currently seeing buffering issues.

The video cache can only be filled using spare network bandwidth, but in this case you will, on average, have little or no spare bandwidth.

Thanks for your reply!
I don’t know how to access the folder you mentioned from my desktop PC but from the rest of your post it looks like it’s kind of a moot point anyways, as the movie in question is simply beyond the Vero 4K’s hardware capabilities. Am I understanding this correctly?

For this particular video, you’ve probably hit the limits of the Vero4K’s network interface. We have seen a few similar cases appearing on this forum, so you’re by no means alone, but for the vast majority of cases, the 100 Mbits/sec interface is enough. (It is for me, for example.)

The main workarounds in situations like this are:

  • remux the video to a lower bitrate;
  • pre-copy the file to locally-attached USB storage; or
  • buy a gigabit USB adapter

Just for your information, the Vero4K’s default cache settings are:

<advancedsettings>
       <cache>
              <buffermode>1</buffermode>
              <memorysize>524880000</memorysize>
              <readfactor>5.0</readfactor>
       </cache>
</advancedsettings>

so there’s already 500 MB of cache available!

Edit: As @fzinken says, 5 GHz WiFi might also be an option in this case, though WiFi in general can be subject to external interference.

1 Like

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

In it’s current form the movie would only be playable if you would either use the 5Ghz Wifi or a Gigabit adapter.

If you ripped the movie yourself try to remux with less connect.

1 Like

Thanks for both of your replies.
I have tried watching the movie via my 5GHZ wireless network which caused more buffering issues than the wired connection. I’ve also tried putting the movie on an external HDD to test playback that way but can’t find a way to access the movie when I plug the HDD into the Vero 4K’s USB port.

It seems like buying a Gigabit USB adapter would involve the fewest hassles. Is there anything I need to look out for when picking one? Are there any recommended models?

I don’t have access to an OSMC device right now, so this is from memory but it’ll be something like (from the main Kodi menu) Videos > Files > Add videos > Root filesystem and the USB drive will be found under /media.

It automatically appears under Videos-Files as eg 29.80GB Drive or using its label (if it has one).

I tried looking in the media folder in the Root Filesystem option and als In the Videos section in general and the drive does not show up. Does it need to be connected to a specific USB port or does it need to be formatted with a specific file system?

Maybe provide some details on the external HDD?

It’s a 2.5 inch 1TB drive that I took out of a PS4 Pro, currently formatted in exFAT. I consider the issue solved for now tho, as I just put in an order for a gigabit USB adapter. Thanks everyone for your support!

It should work. Does it show up in Settings>File Manager? If not, it may be drawing too much power from the USB port.

What’s that, John wick 2? That’s the highest bitrate I’ve found so far and it plays fine

@dillthedog thanks for sharing the default settings. Do you think that lowering the buffer to half would cause less activity on my NAS HDD ? I have the feeling that Kodi constantly tries to keep up with the filled forward buffer and there is too much HDD activity to be heard.

Any way of solving that ?

If your video is 5 GB in size, for example, there’s no escaping the fact that it will need to read that 5 GB from the NAS HDD and send it across the network.

Unless you think that this is adversely affecting other users of the NAS, I doubt if it makes a big difference. If Kodi tries to fill the cache, there will be a higher read-rate up-front, using any spare network bandwidth, but once the buffer is full it will then only need to top it up at the speed it is being “consumed” from the cache. At the end of the video, the cache will be emptied, during which time there will be no further disk activity.

If you want to throttle the speed at which Kodi reads from the NAS, you might try lowering the readfactor value.

Thanks @dillthedog

I just wanted to reduce the activity of the HDDs since they are pretty loud.
Reducing the readfactor value did not fix the job yet.

Hmmmm

Tuning is something that is very much hands-on and often requires a good deal of fine tuning, both of which are outside the scope of this forum.

As I said previously, you’ll always need to read X GB from the file one way or another. Either it’s slightly more front-loaded or it’s more evenly spread but it’ll be the same amount of data either way.

If you want to graph the network traffic on OSMC, in order to get a better feel for what’s happening with various settings, take a look at this post.

The Gigabit USB adapter came in today (Anker brand) and I can play the movie in question with it without issue. Glad I could resolve this with little issue and relatively cheap, shame that the Vero 4K ships with only 100mbit LAN as this has proven to be a bottleneck for some users.