How to add m2ts file to Kodi library?

I have a m2ts file that plays very well on Vero4k+ but I am not able to figure a way to add it to my “movies” library. I’m wondering if it’s because the file extension isn’t recognized by ‘tmdb’. For now, in order to watch I have to use file manager.

The scrapers don’t have an issue with that file extension and I just ran a test and it worked as it should. I would venture a guess that the issue is with the other part of the file path and/or how you have your scraper configured. You would need to provide more details in order to allow anyone to spot where the issue might be, and preferably provide debug logs that contain a library update. Alternatively you could use an nfo file.

I see my problem now. The title of the movie doesn’t match the title of the tmdb entry. Harry Potter and the Sorcerer’s Stone is incorrectly listed as Harry Potter and the Philosopher’s Stone.


FYI is the original title for both the book and the film, so it’s not incorrect. American publisher preferred

You can always use .nfo files if you need to.

Was the issue that it scraped and you didn’t notice since it was listed in the library under a different title? Since the original name you used is one of the alternative titles in the TMDB listing there shouldn’t have been an issue scraping, and it worked correctly when I tested it just now. If you wanted to use the original title there are a few options to change it.