How to add PVR app?

Probably a stupid question, but how do I install an app? I have read that there is an app store, but I can’t find it!
I would like to install MythTV PVR add-on - I installed and enabled the add-on from settings, but it does not appear in the menu.


If it is a stupid question then I have exactly the same stupid question. I can’t find the app store either. I’ve tried to install a PVR from the menus as I used to do with OpenElec Gotham and nothing happens. I’ve tried to install a PVR client from the console using apt-get and I run in to problems with dependencies. It wants to install the old xbmc package, which prevents OSMC from working.

Are PVR clients not in Kodi addons?

PVR addons are included already, check settings>addons>disabled addons


I got my Vu Duo+ to work on OSMC Alpha 4 following this guide for Vu Duo+

The addon was already installed but inactivated, I activated it, filled in all the info, enabled the live-tv but then I had to activate the addon once more (it was still under unactivated addons) and then it worked. Streaming a 2-3 Mbit SD stream consumes about 75% cpu over 4 CPU so plenty of CPU to spare. I’m in a hotel and their wifi is not the best so I can’t try HD channels


Tried a HD channel but bandwith is poor, so I get a stuttering picture due to this. The Pi2 is using omx-h264 codec so the CPU is not as much utilized as with mpeg-2, around 10-15%, very promising and I’ll try some more once I get decent bandwith

Edit 2:
I have now tried HD channel, 13.5Mbit, omx-h264 decoder and 50-75% CPU total. Very nice compared to Pi B+

A SD channel, 3.5-4.0Mbit, ff-mpeg2video decoder and 85-110% cpu. I see no need for the hw license unless you want to support the project.

I don’t find any PVR clients in the “Kodi Add-on repository”.

I go disabled add-ons and enabled the “DVBLink PVR Client”. Whereas previously (Gotham OpenElec) I would have then seen Live TV appear in the menus and be up and running, nothing happens.

I’ve already installed the TVHeadend backend and I know that’s working because I can go to the web admin interface and see all my channels. I can also connect to the TVHeadend backend from the TvhClient iPad application and watch live TV on my iPad. I’ve also got the Live TV service enabled.


You have to enable Live-Tv under settings after you have entered the correct info for your PVR. I had to activate the addon once more for some odd reason

So I did wonder about that… in other words have I mucked it up by first enabling live TV and then enabling the PVR client.

To address this, I’ve tried to go back to disable live TV, so that I can then enable it again with the client already enabled.

Unfortunately, when I do that, every time I go to deselect the enabled flag for live TV, the interface freezes. I can only then recover by restarting the mediacenter service from the console over SSH.

I had a dig around to see if I could work out how to get to the configuration settings via the console over SSH to disable live TV that way, but I haven’t been able to figure out how to do that yet.

Any ideas apart from take out the SD card and start again?

All settings are stored under userdata in a xml file. You should be able to change that value and reboot. Sorry for not being able to be more exact but I’m away from my pi2

Ok, since I don’t remember the sequence of enabling the add-on and live tv I did a fresh install, making sure to first enable the add-on, then enable live tv.
Result: after a reboot the add-on was disabled so I reenabled it and tried to reboot. This caused the Raspberry to freeze. After pullingbthe power and booting again I am back where I started; everything enabled but no live tv in the menu:(

Any ideas?

P.S.: I forgot to mention I am running OSMC alpha 4 on a Raspberry Pi 2. I have done a manual update before setting up the PVR.


I tried on my second Pi 2 and it worked just fine but the order seems to be important. No reboot is reuired

  1. Install the inactiver addon
  2. Configure the addon and activate it
  3. Enable in Settings/Live-TV
  4. Activate the addon yet again

Thanks. Following that sequence seemed to do it for me and I followed your tip for editing the menu settings via the XML file to avoid the freezing of the GUI.

I am having the same problem trying to install NPVR. Previously there was a PVR group under add-ons but now this is gone. Also there is no "disabled add-ons " group and search does not find the ad on. where did it go? !

Doh. After a reboot I found it under “My add ons”