[HOW-TO ALL PLATFORMS]Can I use Netflix on OSMC?(post 4)

Settings for netflix add-on->Inputstream addon settings->Max resolution (both) set to 720p

I used the install script here on my Vero4K, and installed the netflix addon, currently v0.14.5. I can log in, and browse netflix, but whenever I try to start a stream. I get a loading sign for a few seconds. And then nothing more.
In kodi.log I see this:

2019-06-24 22:09:29.591 T:3396563680  NOTICE: Creating InputStream
2019-06-24 22:09:32.040 T:3396563680   ERROR: AddOnLog: InputStream Adaptive: Download failed with error: 420
2019-06-24 22:09:32.040 T:3396563680   ERROR: AddOnLog: InputStream Adaptive: No MOOV in stream!
2019-06-24 22:09:32.252 T:3154977504   ERROR: AddOnLog: InputStream Adaptive: Download failed with error: 420
2019-06-24 22:09:32.254 T:3396563680   ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.netflix/play/show/80177342/season/80177556/episode/80191870/]
2019-06-24 22:09:32.255 T:3396563680  NOTICE: CVideoPlayer::OnExit()
2019-06-24 22:09:32.268 T:4068929536  NOTICE: CVideoPlayer::CloseFile()
2019-06-24 22:09:32.314 T:4068929536  NOTICE: VideoPlayer: waiting for threads to exit
2019-06-24 22:09:32.314 T:4068929536  NOTICE: VideoPlayer: finished waiting
2019-06-24 22:09:34.834 T:3634299616   ERROR: EXCEPTION: XBMC is not playing any media file

anyone an idea what is going wrong here ?

Any chance you are using VPN? 420 error indicates that netflix aint serving you the manifest.

Yes, that seems to be it…
I had a VPN service running on my vero, which I turned off. But I forgot that I still have a transparant proxy set in my network, redirecting http through NordVPN. If i turn that off too, it seems to work…
I didn’t think about that as Netflix on my PS3 works normally with this proxy set up …

Ofcourse I don’t want this VPN to be disabled all the time . Any ideas on how to pass the VPN tunnel for Netflix only? I tried by making ip routes for all subnets listed in AS2906 Netflix Streaming Services Inc. details - IPinfo.io to not go through the VPN. But that doesn’t seem to help. :-/

Hi, Not sure if I am replying to the correct thread, my netflix plugin stopped working two days ago. “Netflix Error , Check the log files” . (I am not sure where they are). I have rebooted, uninstalled the plugin re-installed, rebooted. Checked the Netflix is working on a pc basically everything I can think of.
RPi 3
Latest OSMC
Netflix 0.13.22

I am not sure if these will help https://paste.osmc.tv/elefugesop

I made netflix plugin to bypass my active VPN connection on my Vero4K by adding static routes. And it works now.

However, I’m not very happy with my current solution as I now add routes for all netflix ranges (AS2906 Netflix Streaming Services Inc. details - IPinfo.io) but I also needed to add routes to all Amazon AWS ranges (AS16509 Amazon.com, Inc. details - IPinfo.io) as the netflix plugin seems to depend on some Amazon cloud services.
And those AWS ranges are way too much ranges and makes it bypass the VPN for everything hosted on AWS. I now have about 3046 routes defined…

I do this with this script:

netflix_ranges=$(curl https://ipinfo.io/AS2906 | grep -e "^ *[0-9]{2,3\}\.[0-9]\{2,3\}\.[0-9]\{2,3\}\.0/24" | tr -d " ")
aws_ranges=$(curl https://ipinfo.io/AS16509 | grep -e "^ *[0-9]\{2,3\}\.[0-9]\{1,3\}\.[0-9]\{1,3\}\.0/[0-9]\{1,2\}" | tr -d " ")

for range in $netflix_ranges; do
        /sbin/ip route add $range via dev eth0

for range in $aws_ranges; do
        /sbin/ip route add $range via dev eth0

Has anyone here an idea on how to limit the AWS ranges only to those necessary for Netflix ?

Meanwhile I found out there is probably no way of finding out which AWS ranges are actually used by Netflix, as they even don’t seem to know themselves (https://blog.thousandeyes.com/how-netflix-tracks-ip-addresses-within-aws/)
But I did find that this:

aws_ranges=$(curl -s https://ip-ranges.amazonaws.com/ip-ranges.json | grep ip_prefix | cut -d"\"" -f4 | sort -u)

contains ‘only’ 1045 ranges, and with those, Netflix still seems to work. Better, but still not satisfying…
If anyone knows of a method to call this script when Netflix plugin is started? please let me know. Then I may be able to add/remove those routes when starting/exiting the Netflix plugin.

For those interested, I updated my post [HowTo] Permanent NordVPN tunnel on OSMC to contain my findings on using the Netflix plugin in combination with a VPN.

Thanks Joakim. If I understand you correctly I need to run.

wget https://raw.githubusercontent.com/zjoasan/netflix-install-script/master/netflix_prep_install.sh
chmod +x netflix_prep_install.sh

Then download ( I don’t think I originally used your repository )
wget https://github.com/CastagnaIT/plugin.video.netflix/archive/master.zip
mv master.zip plugin.video.netflix.zip

If you use the script it downloads automatically the latest zip and move it into addons folder, where you can install it.

REMEMBER to uninstall the old Netflix addon

Thanks a bunch, all working now. I owe you a beer. Kids happy + SO happy = me happy

That’s the MAIN part, disappointed kids is survivable, but SO that’s a matter of life and death =)

Glad it worked out.

1 Like

What is the MAX NETFLIX Resolution supports via this ADDON? Any way to get 4K NETFLIX working Assuming I got VERO4K+, 4K TV and 4K Netflix account?

No. As I understand 720 is best to be expected.

1 Like

Thanks @ActionA What recommended settings should I use in NETFLIX APP and also Video stream settings? I can get Nexflix App to open and login but video is very choppy… I got a 100MBPS connection and VERO4K is connected via Ethernet.

Sorry, I personally have no experience using Netflix but your issues sound similar to those I’ve seen solved in this thread. Keep digging or maybe someone who knows more can offer advice.

@sniferx1 If your playback is choppy, you’re probably trying to play something at a resolution higher than 720p. In the Netflix add-on settings, under Expert, make sure you do not have Enable VP9 Profiles or Enable HEVC Profiles checked. Then, in your InputStream Adaptive settings, under General, set Max Resolution general decoder to Max, Max Resolution secure decoder to 720p, and Stream Selection to Auto.

1 Like

Thanks @angry.sardine much appreciated. I got the Youtube 4K streams working without any glitches via below trick and not sure what I need to do the same get this working for the Netflix APP…

Netflix does not allow 4K at this time. It’s them not allowing widevine to access anything better than 720.

1 Like

Thanks @bmillham. I will stick to the recommended settings for now.