[HOW-TO ALL PLATFORMS]Can I use Netflix on OSMC?(post 4)

#445

What is the MAX NETFLIX Resolution supports via this ADDON? Any way to get 4K NETFLIX working Assuming I got VERO4K+, 4K TV and 4K Netflix account?

#446

No. As I understand 720 is best to be expected.

1 Like
#447

Thanks @ActionA What recommended settings should I use in NETFLIX APP and also Video stream settings? I can get Nexflix App to open and login but video is very choppy… I got a 100MBPS connection and VERO4K is connected via Ethernet.

#448

Sorry, I personally have no experience using Netflix but your issues sound similar to those I’ve seen solved in this thread. Keep digging or maybe someone who knows more can offer advice.

#449

@sniferx1 If your playback is choppy, you’re probably trying to play something at a resolution higher than 720p. In the Netflix add-on settings, under Expert, make sure you do not have Enable VP9 Profiles or Enable HEVC Profiles checked. Then, in your InputStream Adaptive settings, under General, set Max Resolution general decoder to Max, Max Resolution secure decoder to 720p, and Stream Selection to Auto.

1 Like
#450

Thanks @angry.sardine much appreciated. I got the Youtube 4K streams working without any glitches via below trick and not sure what I need to do the same get this working for the Netflix APP…

#451

Netflix does not allow 4K at this time. It’s them not allowing widevine to access anything better than 720.

1 Like
#452

Thanks @bmillham. I will stick to the recommended settings for now.

#453

To be a little more specific: you can access 1080p streams on Netflix, but you can’t play them well, and quite possibly never will be able to. YouTube videos can be played using hardware acceleration, but Netflix videos have to be decoded in software - that’s a restriction imposed by Widevine, and which can’t be worked around. So you can play 1080p Netflix videos, but they’ll always be jerky as hell. So the best thing to do is not to try to access anything above 720p.

#454

On another side. I just installed the script and ran it on a vero4k+ and a vero4k.
The installation of all through the script worked on both sides fine.
Executing the netflix addon after that worked on the vero4k+, but failed on the vero4k with an error message and the following log entry.
I then re-imaged the vero4k completely (well, it was a very old installation updated over time) and I thought there was something broken. But after imaging it, same error message shows up in the logs.
Any hint as to what it could be?

2019-07-10 13:39:51.408 T:3664765664 WARNING: [plugin.video.netflix (0)] Backing file does not exist or is not readable
2019-07-10 13:39:56.445 T:4064808960   ERROR: Control 55 in window 10025 has been asked to focus, but it can't
2019-07-10 13:40:20.030 T:3654284000   ERROR: [plugin.video.netflix (1)] Traceback (most recent call last):
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/addon.py", line 90, in <module>
                                                route(filter(None, g.PATH.split('/')))
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/addon.py", line 49, in lazy_login_wrapper
                                                return func(*args, **kwargs)
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/addon.py", line 77, in route
                                                g.REQUEST_PARAMS)
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/navigation/__init__.py", line 21, in execute
                                                executor(pathitems=pathitems)
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/navigation/directory.py", line 44, in root
                                                self.profiles()
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/navigation/directory.py", line 50, in profiles
                                                listings.build_profiles_listing(api.profiles())
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/common/misc_utils.py", line 238, in timing_wrapper
                                                return func(*args, **kwargs)
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/api/shakti.py", line 65, in profiles
                                                return common.make_call('list_profiles')
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/common/misc_utils.py", line 238, in timing_wrapper
                                                return func(*args, **kwargs)
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/common/ipc.py", line 61, in make_call
                                                return make_addonsignals_call(callname, data)
                                              File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/common/ipc.py", line 98, in make_addonsignals_call
                                                raise Exception('AddonSignals call timed out')
                                            Exception: AddonSignals call timed out
2019-07-10 13:40:27.762 T:3639603936   ERROR: GetDirectory - Error getting plugin://plugin.video.netflix/
2019-07-10 13:40:27.779 T:4064808960   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.netflix/) failed
#455

@joakim_s Thank you for your script!

1 Like
#456

I can’t seen any obvious reason, might wanna take it up ate the scripts github page, see link earlier in thread.

Unless you trying to start it right after Kodi has booted, since the is a background process that got to start first.

#457

Well - it was started if I understood it right. Did it exactly as on the vero 4k+ …
Will check today again and start the vero4k (basement in the gym - does not run 24/7). If it fails, will send in an issue in the github page of the maker :slight_smile:

#458

Anyone on Hyperion.ng running this? I have noticed trying to install Netflix or anything needed beta dependencies from the marcelvent repo seem to really screw up hyperion.ng on the Vero 4k+

#459

Netflix addon has no dependecies on marcelvent beta repo, last time i checked.

#460

Hi,

A problem I previously thought was resolved has re-appeared.

I am unable to watch anything when connected to the VPN. I have connected to the same server on my PC and I am able to. The error log is below.

https://paste.osmc.tv/lawapaponi

I don’t understand why I am able to watch on my PC but not on my Pi, even when connected to the same server at the same time.

If anyone could help, that would be great. My wife and kids are getting impatient.

Thanks,
Mark

#461

Just installed Netflix on my vero 4+ for the first time with help of @joakim_s script

Couldn’t have been easier, thanks @joakim_s

I wonder is the chrome os image deleted after what’s needed is extracted from it ?

1 Like
#462

It should be deleted after widvine library is extracted

1 Like
#463

When installing on rpi3 scripted installer seems to go fine but then when I install the netflix plugin it throws an error to check the kodi log. In the kodi.log I am getting the following:

2019-08-21 19:41:59.155 T:1393947360 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type ‘exceptions.LookupError’>
Error Contents: no codec search functions registered: can’t find encoding
Traceback (most recent call last):
File “/home/osmc/.kodi/addons/plugin.video.netflix/addon.py”, line 19, in
g.init_globals(sys.argv)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/globals.py”, line 217, in init_globals
self.PATH = unquote(self.URL[2][1:]).decode(‘utf-8’)
LookupError: no codec search functions registered: can’t find encoding
–>End of Python script error report<–

Is there something I missed?

#464

There has been an update (4 days ago) to inputstream.helper, the addon that downloads the widevine libary.

So I recommend this:
rm -r /home/osmc/.kodi/cdm
cd /home/osmc/addons
wget https://github.com/emilsvennesson/script.module.inputstreamhelper/archive/master.zip
mv master.zip script.module.inputstreamhelper.zip

In kodi:
goto Settings->Addon browser->install from zip
Navigate to Homefloder->addons
choose script.module.inputstreamhelper.zip

Run netflix again, if that doesn’t work run my Netflix-prep script and it downloads the latest Netflix addon again.

1 Like