How to attach Wireless PS3 controller RPI3?


#1

As title says,
Im on Krypton, so it should be straight forward right?
But how does one connect PS3 controller?

Regards


#2

For gaming ?


#3

Well i have retropie (retrosmc) installed in my osmc system

But its both for Kodi and retropie :wink::blush:


#4

No one?


#5

how exactly did you install this? did you start with osmc and then add retropie, or did you start with retropie the install kodi?


#6

Start with osmc and then added retropie, i used the guide on this forum


#7

Guys forget the retropie, i wanna have my PS3 remote to connect to osmc


#8

Pair it via the command line or in My OSMC -> Bluetooth.
I’m not sure if anything further is needed for it to work.


#9

Thanks Sam, but it does not see my PS3 controller in there, it only sees my soundbar (which has bluetooth)
I Tried connecting it with a USB cable, then my PS3 controller shakes like crazy but it will not Work

Edit: any easy guide to connect it throu command line?


#10

I never got it to work on Pi-3 using the built in Bluetooth for Kodi but it works for Retropie on OSMC
I have been told you need a approved Bluetooth adapter to use it on KODI


#11

I refuse to accept that it cannot connect t pi 3 running Kodi,

Sam do you and/or your team have a Solution?


#12

[EDITED ANSWER]

(there already several solutions)

You can use your ps3 controller to use with both kodi ans retrosmc.

  • For kodi17 just follow the instructions in kodi 17 itself when choosing ps3 controller.
    settings, systems, input, peripherals, configure attached controllers, get more …,playstation controller,[select it and configure]
  • For retrosmc, you can use a guide I’ve made some months ago:

Look into this link:
https://discourse.osmc.tv/t/howto-retropie-and-osmc-retrosmc-retrogaming-on-osmc/6671/968?u=nvdias

Good luck.
(and post back your results)


Pair PS3 Controller
#13

yes but i cannot see my controller in>Addons>My OSMC>Network>bluetooth
i can only see my phone and soundbar (wich has bluetooth) ???

so i still help with connecting my PS3 controller with OSMC?!?


#14

PS3 controller does not appear in Bluetooth menu.
Use the peripherals menu as described above.


#15

Try this https://www.piborg.org/rpi-ps3-help


#16

Tryed, still can’t get it to work


#17

Sudo sixpair
Command not found…


#18

have you installed it ?

sudo apt-get install sixad

[edit]
please read my previous post and the link I’ve shared:
Support for dualshock controller is direct in OSMC (Kodi 17).
sixad is needed for support in retropie


#19

I did everything you said above…
Still no work…

May it be because I’m using a cheap Chinese PS3 controller?

Edit: it does pop up under peripherals
http://m.imgur.com/UZ59H0x


#20

As of today, I can confirm the procedure shared by @Rickt1962 works well. I’m using a genuine PS3 controller.