How to boot PI2 when disk from fstab is missing?

I have an entry in the fstab for mounting external ntfs USB drive.
Everything works as it should.
From time to time, I have to disconnect the drive.
When I reset the PI2 afterwards, the Pi2 doesn’t want to boot because the disk from fstab is missing.
i tried to add nobootwait option in fstab, but with no success.

How to boot PI2 when disk from fstab is missing?

There is a ‘wait for network’ option, to allow things to settle and the network to be running properly before trying to finish the boot processes.
I think a search of the forum will reveal it.
However, without more detail of the fstab entry, I might not have the correct idea.

Maybe I wasn’t clear enough.

In fstab I have (actually it doesn’t matter):
UUID=4A7A53A77A538E97 /mnt/temp ntfs rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,nobootwait

Everything works as it should, but if I unplug this external usb drive and reboot the PI2, boot process will stop because of unplugged disk.

If I plug the disk and reboot, again everything is working well.

I tried to add nobootwait option switch but with no success.

My goal is to boot the PI2, even if disk from fstab is not present.

Add the nofail option.

I have just tried it, and it works.
Thank you very much DBMandrake.


For reference, documented here: