How to change how samba shares are displayed/named in the Finder - SOLVED

My Pi’s samba shares that show up in the Finder (Mac here) are displayed as: “Samba Shares on OSMC” (OSMC is my hostname), like this: Dropbox - File Deleted

I want to change that. I managed to do it once, by ssh’ing into my Pi and editing some file, but that was a month ago. I’ve sinced switched to a newer Pi, and for the life of me can’t remember which file it was. I only remember it contained a string like “Samba Shares on %”, or something like that, where % was a placeholder for the hostname, which was pulled automatically.

If anyone knows anything, please let me know, because it drives me crazy :). That name is ugly and too long for the Finder, I would like it to show up as “OSMC Shares” or something similar.

P.S. It’s not in /etc/samba/smb.conf (or I’m blind, because I’ve scanned it about gazillion times already).

P.P.S. Hope I posted this in the right section.


Changing this file would be overwrriten on updates however.

That’s it! Huge thanks :).

I know it’ll be overwritten, but I don’t mind changing it when it happens. After all, it’s not like there are updates every hour.

OK – it will also only update when we update the Samba package, which isn’t very often.

Even better! Thought it’ll get overwritten on every OSMC update :).

@sam_nazarko By the way, is there a way to revert back to previous version’s skin? Estuary is really nice (I especially like improved typography and spacing), but I also really liked having a flat color/slight gradient as a background, instead of a wallpaper :).

Confluence is still available.
We have updated the OSMC skin as well to be a bit more modern and fix some issues.

My boot folder is showing up as a samba share alongside the osmc folder containing Movies, TV Shows, Pictures and Music:

Is there a way to prevent that? I want only the osmc and other folders from my smb-shares.conf to show up, without the boot.

Does removing the automount in /etc/fstab help?

Remove x-systemd-automount, noauto options. This is probably the issue and would have been introduced by

No luck, unfortunately.

  1. removing just the x-systemd-automount, noauto didn’t do it
  2. uncommenting the whole /dev/mmcblk0p1 /boot vfat defaults,noatime,noauto,x-systemd.automount 0 0 line didn’t do it either, and introduced something new: now a new folder shows up as a share, called F0EB-DAA4

Okay – removing the line completely in fstab means UDisks will mount it and use the partition label / ID and mount it to /media (hence the new share).

Try removing x-systemd-automount, noauto again and reboot Pi, then Mac.

Okay, so:

  1. changed my fstab to look like this:

    /dev/mmcblk0p1 /boot vfat defaults,noatime 0 0

    rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)#/dev/mmcblk0p2 / ext4 $

  2. rebooted my Pi

  3. rebooted my Mac

And boot still shows up. It shows up both when I connect as a Guest and as the osmc user.

Ok, will do some digging tomorrow, it’s a bit late now

Ok. I’ll make a fresh install of the newest OSMC + install Samba to see if boot gets mounted, because now I can’t quite remember if that was a problem from the very beginning or showed up later, after some tweaking with various things on my part.

Sadly, boot still shows up as a samba share alongside osmc after a fresh OSMC 2017.02-2 install and installing samba from the App Store.

[15:17] < bonelifer>Roziek:  in /etc/samba/smb.conf add this line to the
          OSMC share block:
[15:17] < bonelifer>veto files = /boot/
[15:18] < bonelifer>then restart samba
[16:16] < Roziek>@bonelifer, thanks, vetoing /boot did the job;

Issue resolve with the help of a user on IRC. Thanks @bonelifer.

True, this seems to do the job, thanks again.

P.S. Would be great to know, though, if /boot showing up as a share by default in the newset version of OSMC is intentional or not (because I could swear it was not showing up when I was still on 2016-12.1).

Had to reboot my Pi and now /boot is showing up again ;x. Not sure what happened there.

To be clear, veto files = /boot/ is still there in /etc/samba/smb.conf, I rebooted both samba and the Pi several times - but no luck, /boot keeps showing up as a share.

Ok, so I found the “culprit”. It’s the [automount template] in /etc/samba/smb.conf:

[automount template]
    browsable = yes
    -valid = no
    valid users = osmc
    path = %P
    hide files = /$RECYCLE.BIN/System Volume Information/desktop.ini/thumbs.db/

If I comment that whole template out, the boot folder is not showing up as a samba share. But then, of course, nor do any external drives connected to the Pi via USB.

I tried veto files = /boot/ within the [automount template], but it doesn’t work.

Any ideas how to solve this?

P.S. As for this moment, my solution is to comment out [automount template] and add my external USB drive as a separate share. It works, but it’s not a great solution; it won’t show any other external USB drives automatically, should they be connected to the Pi, I would have to create a share for each.


Found in /var/lib/samba/share a file name boor. If you delete it, the I desapear… Config is too much comlicated to understand…

I trash the osmc specific samba package and reinstall the debian way : apt-get install samba

@Roziek - I am a little confused if this is solved? The thread has a marked solution, but you later commented that the solution did not actually work?

I just installed OSMC on a new box (Pi 3) and also see the “boot” folder in my SMB shares. So I am interested in a fix, if this worked. Thanks!