How to configure TVHeadEnd with HDHomeRun

Can anyone help to get me past the next step in TVHeadEnd? I’ve got OSMC running fine and was planning to use TVHeadEnd as the PVR to extend my movie library. Initially I have installed TVHeadEnd on my laptop (Linux Mint 17.2) but will move the app to OSMC running on my RP3. The laptop hosting TVHeadEnd also has HDHomeRun Config Gui installed, which scans and find channels which then run in VLC.

TVHeadEnd 4.0.9-13 runs fine on my laptop and finds the HDHomeRun tuner on my network (see picture). Based in the UK, it is DVB-T.

However, I cannot find a way to get TVHeadEnd past the point of recognising the existence of the tuner. I have selected the network of my local freeview TV (Wrekin).

It seems to find a set of muxes but I can’t populate the next tab named services which remains stubbornly blank. Am I missing a step? Is driver required? Any pointing in the right direction is greatly appreciated.

@Dilligaf might be able to help you here.

TVH uses AJAX heavily. It’s worth trying another browser to rule out a problem there.

Haven’t messed wioth TVH in a long time but looking at your screenshots you need to scan the muxes for services then link the services to guide data (channels)

Thanks. But there lies the problem. There is or I have not found an option to scan the muxes. I’ve used TVH before on a desktop with internal TV card and the process was straight forward once the card drivers were installed.

Map TV adapter to local transmitter, which found networks, which then found muxes and I thought the services were discovered automatically after that. I installed the Kodi TVH plugin and lift off. Wel that is off 2 year old memories and after therapy :slight_smile:

I cannot find a method of scanning the muxes. Do you need to install a driver of some sort for HDHomeRun?

No don 't need to install something more. with TVHeadend 4.1.x
I don’t use TVHeadend anymore, and i don’t remember exactly.But i’ve some handmade doc

. Have TVHeadEnd Scan for channels

click “Configuration”, click “DVB Inputs,” click “TV Adapters”
Select Click on “Select TV Adapter” to pull down a list of recognized TV Sources;
Check Enable, Autodetect muxes,
Skip Initial Scan, and Uncheck Idle scanning;
optionally change the adapter name;
click save at the bottom;
Click Add DVB Network by Location, select “your country setting”, select “your country setting…”, click Add DVB Network.

Repeat the above for the second TV Adapter in the dropdown list.

Over on the right hand side of the screen, take note of the following:

Services: 0 Muxes: ?? Muxes awaiting initial scan: “”

The system will scan each Mux (a potential channel) to see if there is a service (an actual channel). When Muxes awaiting initial scan reaches 0, all potential channels have been scanned and the number shown in “Services” is how many channels were actually found.

You can watch the scan by opening the log chevron in bottom right hander corner of screen and enabling debugging by pressing the gear next to the chevrons after the log window is open.

And your can found a doc in the Kodi forum
Hope it’s help

TVH worked before on my linux Mint under Firefox. As Firefox is one of the heavier browsers on a linux platform, what would you suggest? I can try Chrome as you are right, problem solving is usually an elimination process.

This is a screenshot of one of my muxes. It says Scan Status = Pending.

So the pending bit is probably an explanation why the services tab is empty. What do you need to do to trigger the muxes scan??

Thank Michael,

I have TVH v4.0.9. Maybe you can see something from the choices I made why it is not scanning. What you describe is what I remember from using TVH with a dedicated TV card in the PC back in 2014. Now I use HDHomeRun and I can’t reproduce it.

Below my tuners and the settings for the 1st tuner.

The networks tab shows muxes (and I don’t understand why the 2 identical tuners do not list the same number of muxes. But force scan does nothing in the system log area at the bottom i.e. blank.

The muxes tab shows the below. Scan status = PEND.

The Services tab remains blank. Map All does nothing.
I just noted after loglevel debug enabled in the log that the log says several times
comet failure [e=this.el.dom is undefined]

What does that indicate?

What is yout country ??

comet failure [e=this.el.dom is undefined]

some discussion on
TVHeadend Forum
Kodi Forum
try to identify your channels, perhaps something to do with crypted channels.

But back to your config. (I can’t check myself, use DVBLink now)

Please post your network tab, I don’t understand why you have 2 differents networks.
I’m sure that with 2 HDHomerun (4 Tuner) i’ve use the same network.

And try to enable idle scan


I had 2 networks as I added a 2nd on the network page mapped to the same network. I’ve removed that now. Also enabled idle scan for both tuners.

My network tab with log output.

This remains my muxes tab

My dmesg shows the below. I would think some of it is related to the scanning process.
[ 16.204456] cfg80211: Calling CRDA to update world regulatory domain [ 16.221801] cfg80211: World regulatory domain updated: [ 16.221807] cfg80211: DFS Master region: unset [ 16.221809] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) [ 16.221813] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A) [ 16.221815] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A) [ 16.221817] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A) [ 16.221820] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A) [ 16.221822] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A) [ 16.221844] cfg80211: Calling CRDA for country: US [ 16.252106] cfg80211: Regulatory domain changed to country: US [ 16.252111] cfg80211: DFS Master region: unset [ 16.252113] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) [ 16.252116] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm), (N/A) [ 16.252118] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm), (N/A) [ 16.252121] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (0 s) [ 16.252123] cfg80211: (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (0 s) [ 16.252126] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (0 s) [ 16.252128] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm), (N/A) [ 16.252130] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A) [ 17.060847] init: failsafe main process (667) killed by TERM signal

You try to connect with Wifi ?? Are you sure that your RPI3 Wifi works well ??