How to delete video sources not listed in sources.xml?

Since I’ve used pinn-lite to dual boot between OSMC and Recalbox, VIDEOS has more than the 2 NAS shares I’ve added manually, namely


which I don’t want to see there. How can I delete them from this list? I’m not using the library and they are not written in the sources.xml. Using the context menu only yields “safely remove”. Any ideas?


There should be a button on your remote which brings up menu, which you can edit and remove sources. Failing that connect a mouse and right click, should bring up the same menu.

Thanks Tom.

Right, I’m using my TV’s remote via CEC which translates only very few buttons to use in Kodi, none of which is bringing up a menu. According to this, all I have to do is right-clicking on the mouse or pressing c on the keyboard to get the contextual menu. When I do either of this, however, I get a menu swooshing in from the left side (barely readable in German cause the words are too long) with these items:

Add to favourites
Remove safely
Set content

When I remove them safely, they’re back after a reboot. Shouldn’t they be listed in any of the xml files in the .Kodi folder so I could permanently remove them there?

Doesn’t sound like a library action but a removable storage action.

Exactly. And since I’m not even using the library, I simply would like to be able to remove those sources which appear to be links to directories on the SD card.

But I would assume not the SD card but a usb stick.
Provide logs grab-logs -Aso we might see where they come from (my guess is the automounter)

Right, my guess is they got introduced with me installing pinn-lite to get dual-boot. However, I’m not exactly linux savvy, so how do I grab the logs? Logging in via SSH or something? Thx!

Yes, but if that is too complicated for you alternatively you can do via MyOSMC on the GUI

I’ve uploaded the logs to the osmc pastebin. Apparently those dirs are automounted during boot, e.g. Successfully automounted /dev/mmcblk0p5 at /media/SETTINGS. Contrary to the two sources I’d added via the GUI (that show up in sources.xml), a right-click on those does not have Edit Source/Remove source in its context-menu.

@DBMandrake any easy way to exclude those partitions from being automounted?

Not at this time but we want to prevent NOOBS partitions from automounting in the future

So, any ideas what I can do now to get rid of those automounted dirs?