How to edit xorg.conf file with ssh? No write permissions

Hello there,
Thanks in advance for the hard work involved in porting to ATV1 :slight_smile:
I’m looking forward to trying OSMC

Trying to edit /etc/X11/xorg.conf but cannot save it back to the folder using Cyberduck on Mac.

My system is ATV1 running into a Component to RGB SCART converter into a Toshiba CRT TV
Old School but I like the way it does SD.
Have previous experience with OpenELEC and ssh’ing in to edit xorg.conf
The chap Chewitt helped me with some code that he put on a server.
I used putty on a PC to ssh it in:
wget -O /storage/.config/xorg.conf
It worked.

It doesn’t work on OSMC.
The OSMC Wiki shows the code but doesn’t show how to get it into the ATV1.
I found the file in Mac Cyberduck, edited it in Text Wrangler but cannot save it back due to permissions (Deja Vu).
If I use Windows Putty then I can log into OSMC but just have the Command Line box and I don’t know what to type in from there.

Help much appreciated.

Typically I would copy it to somewhere where you do have permissions (/home/osmc for example) and then once SSH’d in then you can move it to the correct location ensuring you use the sudo command to give you elevated rights.

What is the situation right now? Is the file at exactly how you want it or do you still need to make some edits to it? If that file is how you want it the. You can just download it directly to the right location without needing to move it around later.

You could probably just;
sudo wget -O /etc/X11/xorg.conf

Thanks for quick reply. Thought I’d already tried above but perhaps I forgot “sudo”.
Just done it now and it has ssh’d into the ATV. Sadly the code is not working.
Just a load of Failed messages on the boot page.

I will try to make an edit and ssh to /home/osmc then move using sudo in terminal.

How to I move the file into correct directory once in Mac Terminal or even PC Putty?

Once you have copied the file to the device I think the command to move it should be;
sudo mv /home/osmc/xorg.conf /etc/X11/

I started again rebuilding OSMC on my USB stick because it would no longer boot up.
For some reason it is getting stuck at Installing Files.

I will try [quote=“jb2cool, post:4, topic:17605”]
sudo mv /home/osmc/xorg.conf /etc/X11/
[/quote] when I get back to that stage.


Sorted ATV output for CRT TV in Composite mode for 2nd non-RGB Scart Input :grinning:

The old codes from OpenELEC would not work. Unhappy Smile/No Boot Up

So edited 720p version of this: Configuring component output - Apple TV - OSMC
Substituting Nvidia Code:

Option “TVOutFormat” “COMPOSITE”
Option “TVStandard” “HD576i”

Option “Composite” “False”

Not ideal picture quality but better than nothing. Sadly new Virgin box doesn’t have 2nd VCR Scart/Through and it uses the TV’s RGB Scart. Will try to find a way to make S-Video work for sharpness.

For getting code in and out of ATV I used Mac Cyberduck to download xorg.conf, edit in Text Wrangler and upload to /home/osmc folder

To get past permissions using “sudo” and move it to the /etc/X11/ folder I had to use Windows Putty.
Not sure why Mac Terminal wouldn’t work for me.

As below:
sudo cp /home/osmc/xorg.conf /etc/X11/xorg.conf
sudo reboot


Many thanks