How to enable bash

Hi there!
Just tried osmc for my raspberry pi2 and… I love it. Good job guys!
Unfortunately I have an issue now that I can’t easily solve: In my private network is a NAS and I would like to mount that. How can I edit the fstab? So far I haven’t seen ctrl alt f1 working. Also exiting won’t let me into the bash. I am sure there is a way how to get that working?!

Your question is explained in the OSMC Wiki. Have a look at Wiki - OSMC. This should be your first port of call for OSMC help. If you feel something is missing, feel free to edit it or tell us how we can improve it.

Press ESC when exiting Kodi to get to a shell.


  1. While not the physical bash but generally the easiest to change the fstab is login via ssh
  2. You should get into the bash by pressing ESC when existing

Yes, found that site, before, thanks (Accessing the command line - General - OSMC)
Thanks - tried that out with exit so far… didnt get me anywhere since I wouldn’t come to the splash screen. SSH will work I guess… but… you know… would love to have a bash locally.

If you exit Kodi and press escape while it’s restarting it will drop you to a shell prompt.

I get stuck inside the menu upon exiting. Will reinstall and try. Thx so far.

yes, fine now!
Finally … YAY - so happy here :smiley: