How to enable CEC volume control?

Hi, I have Vero 4K+ connected to my AVR (Denon AVR-X3500H) which is then connected to LG OLED55C8 via HDMI ARC.

The problem I’m having is that Vero’s volume control controls its own volume (popup “Volume: 100 %” on upper right corner) instead of AVR’s volume via CEC. The volume control has never worked for me and I’ve owned these devices for a year now. I’ve had problems with CEC in the past with Vero (as usual, damn CEC) but they have resolved on their own, again as usual.

Are there some specific settings that need to be set?


If your equipment is compatible, this will work out of the box when using the supplied OSMC remote.
If you’re not using this remote, I’d suggest trying with this first.



You’re right, I don’t use the remote but when I tried it, the volume control works no problem.

My issue is that in iOS Kodi Remote app and Plex app (I’m using PlexKodiConnect) I can’t control the AVR volume using the phone’s volume buttons or the slider which you can see in the image attached below. It instead controls the volume on a scale from 0 to 100 inside Kodi/OSMC.

If I remember correctly, Nvidia Shield and Apple TV send the volume control on their respective apps to AVR via CEC and it’s very convenient when casting music from a phone which is what I always do when listening to music.

I don’t think this will be OSMC related as we haven’t introduced any changes here

This issue has nothing to do with OSMC, and the behavior would not be any different on another platform. Kodi has a volume action that will switch between controlling its own volume (the round icon) and sending CEC commands instead if it sees a CEC enabled amplifier. The control mechanism that the web interface and remote use usually attach to controlling Kodi’s internal volume adjustment instead the same mechanism the remote uses so you get the behavior your seeing. This is a known Kodi bug/feature and would need to get fixed in Kodi or the remote app would need to be tweaked.