How to enable FanArt in OSMC skin?

I have bad feeling, I’m missing something trival here. This is what I did:

  • System -> Apperance -> Skin Settings -> Background:
    Show background video: ON
    Show background visualisation: ON
    Enable Artist Slideshow: OFF
  • System -> Apperance -> Skin Settings -> General:
    Kiosk mode: OFF

Yet, still no luck - no FanArt in Movies or TV Shows section. I switched the skin to Confluence, to check if images actually downloaded - everything worked like a charm there.

Please, tell me what I’m doing wrong - Is it actually possible, to get this? If not, is there some fairly easy “Hack” for the skin XML files to enable that?


If you go into the Movies or TV library then press left (options), then check the box ‘fanart’ and you should have the fanart background as you scroll through your library.