How to enable playing next video automatically?

I think I may have asked this before but I cannot find a way to show a list of my own topics in this forum so here it goes again:
I have a RaspberryPi3 with OSMC, which is updated to the last version a week or two ago.
Now when I play a video from a file list view and it ends I am brought back to the folder list view instead of the next video starting to play.
It was not like this earlier but now it is.
I used to be able to cursor left from the video file list to bring up a side menu where I could activate “play next” for the folder. But now there is no such command visible at all…
I am using my LG TV remote via HDMI CEC, so please do not advice to right click or similar. I can only use the remote or else I have to connect a keyboard to the RPi3.

https://discourse.osmc.tv/search?q=@Bosse_B

Thanks, I have now bookmarked that list!
However I did not find the auto-play setting amongst these topics so it might have been inserted elsewhere. :frowning:
So the question remains:
How to enable auto-play?

https://kodi.wiki/view/Settings/Player/Videos

I was already there but when I select the autoplay entry I must also select among types of items:

  • Music videos
  • TV shows
  • Episodes
  • Movies
  • Uncategorized
    Since none of the specific items match my videos I selected Uncategorized.

But no playback at end of previous item happens.
I have a folder system which classifies my videos and inside these are a number of mp4 files. The display shows the name (minus the extension) of each file and since the name starts with a datetime they are ordered in time.
What I want is for the next video in the list start playing when the previous video ends.
That is all. These are not some entertainment videos or games or such, just plain video files.

Ok so you are referring to files not in your library. Then in that case press c/menu on the first item and say play from here that will autoplay all files in the folder.

I do not have a “library” I just collect videos on a disk.
Nowadays this disk is in a Ubuntu Server and it uses miniDLNA to share it on the network. The Ubuntu downloads automatically too.

The OSMC box can play from this source as well as from its own internal hard drive.
It seems like the “c” trick only works when playing from the internal drive, though. And I would like to know if even that is persistent?

If not it is no solution because normally when watching the videos I only use the TV remote, no keyboard available. So I cannot do this except by pulling out a keyboard and plug it into the OSMC RPi3…

But the dlna videos are the most current and what I normally watch so if it does not work there I have to give up.

I stopped using OSMC/Kodi for watching when I got an LG SmartTV some months ago and that TV automatically starts the next video in the DLNA feed…
But after a while I got fed up with the poor playback quality of the LG TV, it really soon after starting playing each video makes lip sync disappear! Drifts longer and longer apart until I have to stop playing and start again (at which time it resumes where I left off), then lip sync is OK for a while again.
Never happens with Kodi on the exact same videos.

Suggest to either use NFS or Samba to access the Server than file access would be same as on the local disk

I’ll try that, but I have not found a way to remove a video source, just add it. And even when adding there is no browse functionality, I have to type in the file system path to the drive (/mnt/media for example).

What should I do in order not to have duplicates?
I am talking about VIDEOS/Files/xxx
Here there is a list of sources as well as an “Add Videos…” function.
When I enter that there are 3 different choices to the left:

  • Browse (I have not gotten that to work but it is highlighted)
  • Add (impossible to reach at all)
  • Remove (again impossible to reach)
    One would assume that Browse should show a navigation dialogue where one could navigate sources that are not already “registered”, but it does not.
    Instead I am thrown onto this virtual keyboard, which is English to boot whereas my keyboard is using a Swedish layout. So keyboard keys are not producing the correct characters and delimiters.

And Remove (if possible to reach) should show a list of already configured video sources from which to choose what to delete.
Right now I see no possibility at all to remove any source even erroneously added…
Terrible GUI…

Have you tried “Up next” addon? , Don’t remember if it was library based.

If you don’t want to keymap some working button on your remote to work as a ‘context menu’ then an alternative would be to go into settings>media>videos>default select action> and set this option to “choose”. What this will do is bring up a context menu when you click on an item with the OK/select button of your remote (the button inside the direction keys). When this menu comes up you can select “more” which will give the normal context menu options on videos, including the “play from here” which will make the videos automatically play one after another. If you want to play a single video without bringing up the menu then you should be able to just use the “play” button on your remote.

Just go onto the source and press c (context menu) and choose remove source. If you don’t have a button for context menu (on my TV remote it is the option button) than follow the advice from @darwindesign.

To add a server mounted directory you either can use the Add Videos - Browse - Network File System.
You don’t have to type \mnt\media, just go Add Videos - Browse - Root Filesystem then you can browse to any local or remote folder you have mounted.
While I would suggest to go via a kernel mount (either FSTAB or autofs), see these how to’s.