How to exit sleep mode

I just received my Vero 4K a week ago. I made every update, and setup HDMI-CEC which works as good as my old OSMC on my Pi 2.

Now if my Vero 4K enters sleep mode (red light), I can’t find any way to wake it up. I tried the TV remote (HDMI-CEC) and the Vero 4K remote (with the dongle attached), nothing seems to be able to wake it up.

Tried to ping and to SSH into it without success. The only way I found to be able to use it again is to unplug and re-plug the AC adapter.

Any help?

Thanks

I think the vero 4k is a always on device

Red light means OFF. There’s no sleep mode. The only possibility is to unplug power and plug in again.

From what I understand, the Vero 4K is designed to be an “always on” device. What could trigger it to power off?

Nothing (other than going to the power menu) would trigger that. If it happens frequently I suggest you enable debug logging and then after it happens next time you restart the device (unplug and replug) and then directly upload the log files.
See here for details

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Selecting Power Off or running shutdown -h on the CLI

Sam

I found the issue.

My Vero 4K is connected to my TV HDMI-CEC port. This allows me to control my TV and my Vero 4K through the same remote (Logitech Harmony 650).

On my Harmony, if I choose the “Watch a movie” activity, it sends these commands to my TV :

  • Power
  • Set HDMI to HDMI-CEC

It seems that the “Power” command is proxied to my Vero 4K, and the latter interprets it as a KEY_POWER, shutting itself down.

Now I’m not sure if I setup my Harmony correctly, but using the default remote from my TV results in the same behaviour.

Is there a way to “ignore” this KEY_POWER signal from the HDMI-CEC?

Thanks

It can be configured as noop in keyboard.xml I think.
Do you have a Samsung TV by any chance? I’ve just had a similar report of this issue

Sam