How to force Audio from HDMI to Audio Jack?

Hi There,

is there a way to force the audio output from HDMI to the audio jack? The only solution I could find on the internet is the amixer cset but that command doesn’t work with OSMC.

Does anyone know an alternative? (and also a way to change it back afterwards if needs be)

Kind Regards,

Yes, the option is inside settings>system>audio options. Select the analogue audio option or both HDMI and analogue.

Thanks for the reply, but when I change it, nothing happens, I’ve selected analogue and it still plays via HDMI

This works fine for me.
I’m using a raspberry pi model B.

Is it possible it could be a pi 2 problem?

Or rather, the the analogue does work, but ONLY plays the sounds like menu scrolling, not actual video playback. Is this meant to happen?

Problem solved, like an idiot I had the keep devices alive for 1 minute, turned that off and it worked fine.

Thanks for your help!

Hi Froobage,

I have the same problem. When I am streaming audio via bluetooth to my pi, the sound goes to HDMI to my TV. Even though I’ve configured in OSMC the Audio output to “pi analog”.

But if I stream audio via airplay, then everything works fine.

How could you solve it?

thanks a lot

No you don’t have the same problem, and please don’t post the same problem in two different threads.

The a2dp package does not currently send audio through Kodi - this means that the audio settings in Kodi do not affect the destination.

Thanks for this! Solved a problem for me!

Only slight problem I’m left with is that using Yatse as remote, the sound on/off toggle has become inverted: so ON is actually OFF and vice versa.

Thanks! Worked for me as well. On the Raspberry Pi 3, seems there’s about a half second delay in speaker output from HDMI to the audio output. A little shorter delay may be livable, but doesn’t even sound like a concert hall echo.

Is the audio ahead of the picture or behind ? Are you sure it’s half a second ?

If the audio seems to be ahead of the picture then this is expected - analog audio output has zero delay/latency, however HDMI picture and audio always has an inherent processing delay in the TV/display - typically this is anywhere from about 40-150ms on a modern LCD TV, and it depends greatly on what post processing modes you have enable such as frame interpolation (“smooth” mode) etc…

If you use HDMI audio the delay of the picture and audio is equal so there is no problem - the TV knows to delay the audio to match the image processing delay because it knows what its own image processing delay is.

If you use HDMI for video but analog for audio the Pi has no idea what the image processing delay of the TV might be - so inevitably the image lags behind the audio by an amount equal to the processing delay of the TV. With lots of post processing options enabled (especially frame interpolation) the delay can be substantial.

To fix this you would need to either set a default audio offset for all videos (through the OSD controls) or set a default video delay in advancedsettings.xml. My primary Kodi box is a Mac Mini with DVI output - so only the image is sent to the HDMI TV, analog audio is routed directly to the AV amp - in this configuration I need to set an audio delay of about 150ms, but this depends on which image post processing settings I have enabled on the TV, so I leave those settings alone.

1 Like