How to format EXT4 (or best format) and best hard drive?

Logs are uploaded - do you need the link or is it a general site location you already know?

Yes, I tried using sda2 and it starts hitting errors at a certain point in the command lines. I have no need for the EFI that I know of, but disk utility won’t allow me to format it with a single partition due to the drive size.

I’m a bit lost to be honest. I’m learning terminal command lines through this process - very little knowledge outside of what I’ve learnt on this forum. Appreciate the help.


This is what I did with a second drive. It also had the EFI partition.

If you try this it should work:

osmc@osmc:~$ df
Filesystem           1K-blocks    Used  Available Use% Mounted on
devtmpfs                774688       0     774688   0% /dev
tmpfs                   899236    8688     890548   1% /run
/dev/vero-nand/root   14499760 2253176   11486984  17% /
tmpfs                   899236       0     899236   0% /dev/shm
tmpfs                     5120       0       5120   0% /run/lock
tmpfs                   899236       0     899236   0% /sys/fs/cgroup
/dev/sda1           3906982908  371488 3906611420   1% /media/Elements SE
tmpfs                   179844       0     179844   0% /run/user/1000
osmc@osmc:~$ sudo umount /dev/sda1

not sure if needed but this is what I did. I use umout to unmount both partitions.
add this:

osmc@osmc:~$ sudo umount /dev/sda2

osmc@osmc:~$ sudo dd if=/dev/zero of=/dev/sda1 bs=1M count=64
64+0 records in
64+0 records out
67108864 bytes (67 MB, 64 MiB) copied, 2.54129 s, 26.4 MB/s

and here I added this, because I thought I needed to do this for both partitions:

osmc@osmc:~$ sudo dd if=/dev/zero of=/dev/sda2 bs=1M count=64
    64+0 records in
    64+0 records out
    67108864 bytes (67 MB, 64 MiB) copied, 2.54129 s, 26.4 MB/s

osmc@osmc:~$ sudo fdisk /dev/sda

Welcome to fdisk (util-linux 2.29.2).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Command (m for help): d
Partition number (1,2, default 2): 2

Partition 2 has been deleted.

Command (m for help): d
Selected partition 1
Partition 1 has been deleted.

See my above post to format the two SDA partitions.
Samba is an issue on a Mac. For me to get it to work properly was by installing the program SMBUp.
However, I was just checking now and it appears it might not be needed for connecting to the Vero.

You do have to install Samba on the Vero itself. In the Vero app store you can download it.

In the share settings of my Mac I have SMB enabled.
When trying to access the shares on your Vero you go type this in your browser: smb:// (use the IP address used by your Vero)
You get a pop-up asking you to open Finder. Do that and enter the password. Standard password is OSMC.

OK - we’re in business!!
Format of the drive went perfectly. I seem to have managed to get smb working again, although not sure what the issues/fixes were. Trying a file transfer now. Will confirm if successful.

Really appreciate the help. Was starting to think about alternatives to the Vero!!

Seems you got already helped with the instructions from @bezulsqy. While I am suprized that it worked as it deleted both partitions and wouldn’t have created a new one.
But if you are up and running sounds good.

After following @bezulsqy post above, I then continued with his previous thread referenced further up this subject about how to format ext4. By completing all of that it seemed to work.

I’m just playing back a movie (I’ve dropped one film mkv file onto the 8TB drive) and am assessing playback - there still seems to be very very slight flickers. I’ve checked the frame rate settings and have it on auto adjust. Should I be looking at any other settings? I’m about to test with another film.

You have your UI set to 1080i and afaik that breaks refresh rate switching still. I would recommend changing that to 1080p.

ok done that. judder seems sorted. Thanks

Tried copying files from my old drive over to the new one using vero and I managed to brick it. Disconnected the drives and the new one (ext4) now shows up as EFI, so I assume I’ve screwed up the format. I’ll try everything from scratch again at some point. Bit sick of this now and need to take a break.