How to format EXT4 (or best format) and best hard drive?

Hi All
After a recently (partially) corrupted external drive, I’m sorting a new drive and maybe a new format.

I use a mac predominantly, but have access to windows machines. I previously formatted to exFAT, but the drive was probably 70% full and was starting to have very slight flickering during playback, and then i lost about 20 movies or so (when it corrupted).

Firstly - I need to get a new drive. My previous was an 8TB seagate. I use the nero USB splitter, so I could use several smaller drives if preferable. Does anyone recommend any particular drive?

Secondly, I’ve been trying to figure out how to format EXT4. Using a mac for this is a pain, and I though windows would be easier, but after downloading some free software it still doesn’t work on the test drive I was using. I don’t know linux, so ideally just need plug and play style options. Any recommendations on programs or workflows.

Basically - I need to use windows or mac, simple as possible to load a bunch of movies onto external hard drive(s) for best playback experience. Any help greatly appreciated.

Cheers.

https://discourse.osmc.tv/t/best-hdd-format-for-vero-4k-and-how-to-do-so

I’ve used MiniTool Partition Wizard on Windows to format drives in ext2 and ext4 in the past, and it worked okay.

I assume there’s some reason why you can’t just keep the files on a Windows PC or Mac and stream them across the network for playback…?

check the link @k2u3 provided.
It shows step by step how to do this. It actually is not that hard using a mac.
Use terminal on your mac to access the Vero through ssh.
Connect the HD you want to format to the Vero. Disconnect any other drive from the Vero so you don’t format the wrong one by accident.
And follow the steps in that other thread.

When you are finished you can access your drive through Samba. You might need a program called SMBup on your mac because SMB/Samba can have some issues.
This way you can transfer files from your mac to the ext4 drive. Transfer speeds are fine (also see that other thread).

If you have any issues let us know.

Thanks,
Thats a long thread that was linked to, so hopefully I’ve picked out the right bit:

I’m assuming you mean for me to try the Mac version of that sequence (using terminal).
If so I’ll give that a shot today and let you know how I get on.
Cheers

Yes. Last post of that thread is my format session using terminal. There you can see all the steps as they appear in terminal.

Great - I’ll give this a shot later (when the kids give me a break!).
Will let you know how I get on.
Thank you.

In my opinion the drives inside of the current WD Mybook/Easystore 8TB and larger (single disk versions) are preferable to other current options including running more than one smaller drive. I also run a full drive scan with the manufacturer’s utility before I put anything on it to act as a stress test and performance optimizer. It is probably worth noting that this is a slow process (8+hrs on the largest drives).

This worked great thanks. Took a few attempts as the test USB i was using was exfat and seemed to throw up a few different results to your thread. but when I did it as a NSTF (or whatever that format is) it worked exactly the same.

Transfer speed of about 30gB took 20-30min over wifi, so assume that’s ok.

next step - get a new hard drive and transfer everything across. So is there any way to do a bulk transfer with quicker speeds? My mac won’t recognise ext4, so not sure how I can but 6TB from the old drive over to the new?

Sounds good - this is the kind of advice I need, as I have zero knowledge of this.
Thanks!

I have no personal experience but…

thanks - I’ve read through a bunch of those and I start to get out of my depth quickly. Installed Fuse, then couldn’t get the add on for ext4 working. looked at brew and got nervous, which lead to me posting on here.
Thanks anyway though.

I would then suggest plugging both drives into your Vero and use the file manager in settings to do the initial transfer. Although you will be restricted to USB 2.0 transfer rates this would be preferable than a bulk transfer over wifi. The interface may take a bit of getting used to but basically you would go to the right pane and navigate to the new drive where you would like your files moved to. Then in the left pane you would navigate to your old drive and context menu on a folder and select the ‘copy’ option.

Great idea- I didn’t know this was possible. Will try it once I have the new drive.
Thanks again.

Is this the ‘current’ model you’re referring to?

Yes. What i’m referring to basically is that in the lower capacity My Book’s you will usually have lower end drives in them (which are still just fine for most applications). As the lower end WD drives currently are not manufactured in the 8TB and larger sizes what those units contained in them so far have normally been either a red, or a white label red variant, with many of the current ones being the helium filled ones. I have had a good track record with these drives and I prefer that they are running slower (cooler/quieter) than most of the offerings found elsewhere.

ok - so received the new drives, and am struggling to format them ext4. They seem to partition when formatted as NTFS or ExFAT, due to using GUID. this then shows up as SDA1 and SDA2 on the osmc - and that’s where it starts to deviate from your terminal command lines. Ultimately it doesn’t show up on the osmc.

To make things worse, Samba doesn’t seem to work now either. I can’t seem to connect.

Any thoughts.

Post output of lsblk -f and paste-log -A

osmc@osmc:~$ lsblk -f
NAME FSTYPE LABEL UUID MOUNTPOINT
sda
├─sda1 vfat EFI 67E3-17ED /media/EFI
└─sda2
mmcblk0
mmcblk0boot0
mmcblk0boot1
mmcblk0rpmb
osmc@osmc:~$ paste-log -A
curl: Can’t open ‘-A’!
curl: try ‘curl --help’ or ‘curl --manual’ for more information
curl: Can’t open ‘-A’!
curl: try ‘curl --help’ or ‘curl --manual’ for more information
Unable to upload log. Please check your internet connection.
osmc@osmc:~$ paste-log -A
curl: Can’t open ‘-A’!
curl: try ‘curl --help’ or ‘curl --manual’ for more information
curl: Can’t open ‘-A’!
curl: try ‘curl --help’ or ‘curl --manual’ for more information
Unable to upload log. Please check your internet connection.
osmc@osmc:~$

My mistake it’s grab-logs -A

So your disk has an EFI partition first. So if you want to use it like that you need to use /dev/sda2 for the format command.
Alternatively you could remove both partitions and create a single new one (if you want to do that I can give you the commands).