How to get the onboard wifi working?

Got my Vero 2 today, was wondering where the wifi adapter is in the settings, just can’t find it. SSH/ifconfig lists only eth0 and lo.

Can you log in via SSH and run dmesg | paste-log


Thanks for the quick reply, Sam.

I’m investigating this. I’ve had a look at a unit and noticed that sometimes WiFi isn’t showing up.

It’s a little late here but it does not appear to be a hardware fault, but rather a software issue.

I’ll follow up shortly


Same problem seems to be here. I got my vero2 this morning, but no wifi to set up:

We should have a fix out for this later today. To install the fix you would need to temporarily connect via Ethernet then check for and install updates in My OSMC.

We’ll let you know when this is ready.

1 Like

Great, thanks :slight_smile:


I’ve managed to reproduce the issue and believe I have a solution now. I’m currently compiling it, and once Jenkins is done, I’ll verify there are no regressions and I’ll push it as an update.

I’ll let you know when that’s done



@jan @belalseman:

Can you both try updating through My OSMC Updates while temporarily connected via Ethernet. You should receive a kernel update that will reboot the system after installing.

You can check that you have the new kernel by running uname -r which should report 3.10.94-22-osmc.

Please confirm whether this resolves your issue with no Wireless in My OSMC->Networking. If for some reason it does not, please provide a full set of debug logs using the My OSMC log uploader.

OK, so the good news is that I can now access the wifi part of settings. The bad news is that when I selected my SSID and entered the PSK, the system did the whole sad face crash affair - before coming back with wifi working. Not a huge problem but a crash on entering PSK seems a bit…odd?

Anyhoo it’s past 1:00AM here, and I’ve been the pub, so I’ll do some testing tomorrow and let you know if all is well. Currently seems OK - apart from the aforementioned odd crash - and the Vero2 is close enough to my AP to make sweet sweet love to it, so should be fine, but I’ll keep you posted.

I think this is a bug in My OSMC itself. I connected via the command line OK, so hardware should be good and we are probably just looking at a software issue


The sad face Kodi crash that occasionally occurs after entering the passphrase is a known bug in My OSMC that has been lurking for a long time but has so far resisted all attempts to be found and fixed…

It’s unrelated to the problem you were having before, also happens on the Raspberry Pi versions of OSMC, and as you noted the wifi connection does get saved so is working by the time Kodi launches again.

Thanks for confirming that your wifi is now detected and appears to be working. :slightly_smiling:

Just FYI.
I had exactly the same issue, wifi was not detected, I used Ethernet and updated via ssh. When wifi was detected and I entered password, I got the sad face but after a reboot all worked.

Thank you very much for the fast fixing. Same here, wifi ist working, but got the sad face at first connection.

A log of the crash would be good. It is however, nothing to be concerned about.