How to get USB Wifi TP-Link TL-WN722N going with Rapsberry Pi 2 Mode B and OMSC Alpha 4

Hi there,

I was using a Raspberry Pi Mode B as media center running Raspbmc for quiet a while and had to try out the Raspberry Pi 2 immediately. Installing OSMC Alpha 4 was quiet easy and after switching the skin to Confluence, I felt familiar again;) The only issue: My USB wifi stick (TL-WN722N) didn’t work at all. Took me a days and a couple of hints I found in the web: First link: Enable wifi under GUI See post below for second link.

Here the steps, which worked for me:

  1. Set Up OSMC Alpha 4 from scratch, to make sure you didn’t mess anything up before by trying to get it going. Choose wired connection.

  2. Plug in the network cable and wait for OSMC to be installed

  3. Log into OSMC from a laptop or PC via ssh: ssh osmc@192.168.178.20, replace IP-Adress with your IP-Adress, password = osmc

  4. Update system: sudo apt-get update && sudo apt-get upgrade

  5. Install some helpful packages: sudo apt-get install wireless-tools usbutils firmware-atheros

  6. Download firmeware: sudo wget http://linuxwireless.org/download/htc_fw/1.3/htc_9271.fw

  7. Copy firmeware: sudo cp htc_9271.fw /lib/firmware

  8. Restart: sudo reboot

  9. Enter connman network manager shell: connmanctl

  10. Activate wifi, since you choose the wired connection during the installation setup: enable wifi

  11. Check if wifi is listed: technologies
    It’s supposed to look like this:
    /net/connman/technology/ethernet Name = Wired Type = ethernet Powered = True Connected = True Tethering = False /net/connman/technology/wifi Name = WiFi Type = wifi Powered = True Connected = False Tethering = False
    Before activating wifi, only the first entry is returned.

  12. Scan available wifis: scan wifi
    Should return: Scan completed for wifi

  13. Register agent: agent on
    Should return: Agent registered

  14. Get available wifis: services
    Should return all available wifis in a list:
    ESSID1 wifi_code1_managed_psk ESSID2 wifi_code2_managed_psk ...

  15. Connect to a network Wifi1: connect wifi_code1_managed_psk
    Replace wifi_code1_managed_psk with the long string to the right of the wifi essid of the network you would like to connect to. Should returne something like:
    `Agent RequestInput wifi_code1_managed_psk
    Passphrase = [ Type=psk, Requirement=mandatory, Alternates=[ WPS ] ]
    WPS = [ Type=wpspin, Requirement=alternate ]

Passphrase?`

  1. Enter passphrase of your network and enjoy!

Hope this is helpful to someone.

Windy

PS: I’m no linux crack, so feel free to comment;)

1 Like

For some reason, I couldn’t post the two links I found in the first post. There was a warning saying something like: “New users can’t post more than two links in the first post”. Anyhow:

http://elinux.org/RPi_Peripherals#Wireless:TP-Link_TL-WN722N_USB_wireless_adapter.28Debian_6.29

Hello.
I believe I’m having some problems with ssh. I’m using Putty but when I try the sudo update command I get “Failed to fetch” and a few web addresses so I’m assuming its not connecting to the internet. I don’t know if their are certain settings I have to change in Putty before I start ssh. Help would be much appreciated. I have the same network adapter so this would be wonderful if i can get it to work

Sorry, i’m running Ubuntu. But I’m pretty sure, you’ll find plenty of help in other forums…

Hi Windy, could you tell me if the WN722N works ‘out of the box’ and configurable through the GUI in the RC now? The reason I ask is it’s a remote installation I have no physical access to. Thankyou in advance.

Since it’s running now, I didn’t update it: Never change a running system;)
I could test it out on another sd card next weekend. I’ll get back to you…

That would be awesome thanks!

WN722N works out of the box and wifi is configurable through the GUI with OSMC RC.
After first boot it takes some time during which installing is completed. Afterwards there are some options to setup e.g. language of GUI. I’m not sure if you can do this with ssh…

Good luck!

Ah great! Thanks Windy!

Hi,
Thank you for sharing your experience.
I do have the tplink adapter and I am presently connected via wired, the adapter is plugged in , it is detected
/net/connman/technology/wifi
Name = WiFi
Type = wifi
Powered = False
Connected = False
Tethering = False
however it needs activating, when i do activate it either via the myosmc network tab or via the ssh I lose control of the rpi it simply disconnects from the network since I notice everytime I activate the wifi it disconnects the lan so putty can not see the lan ip anymore and the mobile remote Yatse also loses control of it, I must say that i am using the rpi 1 B+ and I installed osmc on a usb stick so the two ports usb ports are occupied by the stick and the adapter.
I could not figure out how to overcome this issue.
Thanks

If you are still using Alpha 4 please do a fresh install (not upgrade) to RC2, run updates, and you should find these problems are all fixed.

Thanks for the tip :smile:
I checked the image I installed: OSMC_TGT_rbp1_20150331.img.gz that is the RC1, so it is not the Alpha4, I am downloading the RC2: OSMC_TGT_rbp1_20150412.img.gz, hopefully it has the fix for the lan disconnect
update: unfortunately the same problem is still here :frowning: .Thanks anyway.