How to get Vero2 to full CPU performance


I want my Vero2 at full performance (1.6Ghz) not only 768Mhz.

What is the right way to do this permanently, if i change the speed in a file on vero at the next start or in about 5 min something overwrites this status, and it is slow again.


I assume that is automatically controlled by the CPU governor which adapts the frequency based on the load.
You should see it to increase above the 768 when you put respective load onto the Vero2

no there is no increasement, i found the file where the governor is, and also tried to change this, there are many instructions to do this on a normal linux.

But Sam once told me this is blocked because of Temperature etc. and he will access it if it is needed, but i have a Skin that is not running smooth because of this low cpu management and i want my box to have full speed.

Need a way to do it permanent


As @fzinken says, there is no need to change the CPU governor or scaling settings manually. If there is a significant system load, the CPU will scale up accordingly within temperature limits (trip points). You can load the ‘performance’ governor which will constantly run the Vero 2 at 1.6Ghz if thermally safe to do so.

However, I suspect this will not resolve your situation. Does ‘top’ show Kodi is stressing the ARM?

The Vero 2 uses DVFS (like a Raspberry Pi), you can force a performance governor and you will always run at 1.6Ghz, provided that thermal trip points are not triggered. If they are, there will be a message in the system journal informing you of this.

And can you please tell me how to do this permanently?

If i write
echo performance > cpu0/cpufreq/scaling_governor

it just changes the CPU Freq for a short time but does not stay.


You can add that in to rc.local after a sleep (or create a unit where it starts after perftune)

I think you are missing the point that this won’t improve things however.