How to get Wireless usb adapter to work as an AP (TL-WN725N ver.2)


I’m new to osmc.Tried using this as an AP on osmc but didn’t work. Any solution to this?

Error message when trying to enable tethering on osmc : “Error enabling hotspot - see log for details”

Wireless Usb Adapter : (TL-WN725N ver.2)

Thanks in advance.

I have done it on my Linux computer with that same adaptor by replacing hostapd with a custom version (that is all I did)

A quick search shows people doing it on the Pi also

Extra note here is a great shell script front end to configure everything and start a AP GitHub - oblique/create_ap: [NOT MAINTAINED] This script creates a NATed or Bridged WiFi Access Point.

Thanks for the reply. Just tried this :

Got no errors but the AP only appeared once and disappeared while the system is still on. The wireless adapter is still blinking though. Any clues of what went wrong?

I’m not sure, I have never had troubles with that adaptor mine just works.

i see. well just got it to work but it’s stuck in “obtaining IP” for android devices. Laptop works fine. Anyway thanks, at least it works but it has to be configured using the terminal and not through the GUI. Will try the other links.

I have had similar problems. Originally, this was fixed by:

It worked fine until the most recent update - now I am back to my android phone not being able to connect, or connecting and immediately disconnecting :frowning:

Should also add that only selected wifi adapters support tethering (and not the most common one). I am not sure about TL-WN725N. I asked about particular models in this post, and was told that you need a chipset that’s supported by the nl80211 driver and supports the AP mode. There are some links in that post that might help you find out about your particular dongle.

Thanks. it helps. been busy these few days so am not able to reply frequently. Well guess i will just have to purchase another wifi dongle for the moment or revert to my old bulky wifi dongle. Strange that both of my older wifi dongles works just fine (Wifi & AP). Which are the TL-WN727N v1 or v2 and a getnet wifi dongle. Will do a little digging on the drivers, if i have the time. By the way, do the original raspberry pi wifi dongles work fine with OSMC?

Depends what you mean by “work fine”. From what I understand, they work well for internet access, but not for tethering.

I just got tethering to work fine with my TL-WN725N v2 under OSMC. Just note I didn’t use the GUI to turn it on and even ignored connman totally.

Here is the exact procedure I did

  1. If installed remove any old hostapd
  2. Install some needed programs

sudo apt-get install iw wireless-tools dnsmasq haveged

  1. Get / compile / install new hostapd (source

tar -zxvf v2.0.tar.gz
cd RTL8188-hostapd-2.0/hostapd
sudo make
sudo make install

  1. I prefer this shell script to configure and start the tethering
    GitHub - oblique/create_ap: [NOT MAINTAINED] This script creates a NATed or Bridged WiFi Access Point.

  2. Start tethering
    create_ap wlan0 eth0 --driver rtl871xdrv whateverssidyouwant whateverpassphraseyouwant

  3. Read that scripts instructions to learn how to make it a daemon and add it to /etc/rc.local if you want to start it at boot. Or find a better way to start it, I never really looked into it.

Finally it works. Thanks for all the info. Just hope it stays functional. Sorry about the late reply.

Does it work using the steps outline by @shadow, or natively using the GUI?

Only works with the steps outline by @shadow which are through the terminal. GUI will still give you the usual error.

hmmm… I think I followed the steps correctly, but seems to be taking a very long time to setup the wireless AP? It’s been stuck on rtl871x_set_key_ops for about two hours, with this line repeating about a dozen times so far. Does that seem right?

edit: well, definitely not right - I’ve let it continue to run overnight, and just more of the same. I can see the AP using my phone, but cannot connect to it.

Hi I following your steps, it seems everything is ok during my settings, but when I tried to connect my phone to Pi, it gave the prompt “the password is wrong”. Could you please give some suggestions?

I am using the latest OSMC version ( Feb.2016)(kernel is 4.4.3)

I don’t think it make sense to ask such a question in this thread which is related to a specific wifi adapter.
Suggest you open a new thread explaining your problem and how you try to access OSMC (ssh or web).
Also first read thru the WIKI that you have checked everything there.

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Sorry, I forgot to provide some information.

In fact, I used the same usb wifi adapter as @shadow, that’s why I asked him/her for help.
I don’t think opening a new thread is better because it is related topic.
In any case, I need to provide more trace for this problem.

Are you sure you typed the password correctly? I have never had a problem with that. Maybe for test cases try easy to write passwords or none at all.

For the earlier post the rtl871x_set_key_ops is normal output that will always happen with that adaptor.

Yes. The password should be correct.
I tried with the latest standard raspbian and it has the same result. so I think it is not related with the OSMC. I will try it on my laptop and check if it can work.