How to Have OSMC Auto Select Dolby

At one time, when ever I played a video with a stereo and a Dolby track, the system would automatically select the Dolby track. Now, for some reason, it always selects the stereo track and I have to manually switch to the Dolby stream for every video. I have selected “make this the default setting” but that doesn’t seem to have any effect. Any ideas? Thanks

No one?