How to install CouchPotato and SickChill on Raspberry Pi


Hi! I followed your tutorial and it’s just awesome! It’s my first time with the RPi and your tutorial for sure made everything a lot easier.

I read all the comments and found a similar problem as mine.

Every new tv series episode and movie that it’s created in my Downloads folder with 0755 permission, so the post-processing routines do not work and are sttoped with the message the file is locked. I tried deleting the torrent files from transmission but the message is the same.

But, when I run the command sudo chmod -R 775 /home/osmc/Downloads, permissions are corrected and post-processing runs just fine.

That’s the result of ls -la for my Downloads folder:

drwxrwxr-x 3 osmc osmc 4096 Sep 22 22:46 .
drwxr-xr-x 9 osmc osmc 4096 Sep 18 23:48 …

Any help would bu much appreciated.




sudo chmod -R 775 /home/osmc

It looks like the folder /home/osmc only has permissions 755 which are possibly being inherited.

Send me a PM if you’re still having issues after running that command.


Hello after a few months running i just hit a wall. I have 2 diff hdds each is having different shows when i added the shows from the folders, sickeage did pick up the destination folder but when it snatches the episodes transmission downloads them to the drive thats set in its configuration file. How can i resolve this?

  1. Settings > General > where the files of shows are located > MAKE SURE BOTH TV SHOW FOLDERS ARE ON THE LIST

  2. Shows > Show List > Show > Edit > Change location to where you need it saved.

That should do it.


That’s how i have it set up. Maybe transmission default folder is overriding it?

Yet everything goes to media/mypassport/media/tv


does it matter where transmission folder is set to download or does sickrage configuration overrides the download folder?


Sickrage overrides


It will be the 8th time I’m formatting and installing from scratch. Sickrage after one or two days does not start anymore, it appears as a timeout error.

Anyone can help me?thank you all!


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload some logs. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.


Try with another SD card, maybe this one have corrupted sectors.


Did someone add a nginx server to this configuration ? If not could I install a nginx server before all of this servers (it’s to make subdomain and port redirect)
Sorry for my english I’m not.


Hi to all, I have been using for years CP and SR. But yesterday out of nothing Couch Potato stop working, I don´t know what happen. I´m running Kodi 17.3 on a raspb 2.

I checked the service with: sudo systemctl status couchpotato.service
* couchpotato.service - CouchPotato application instance Loaded: loaded (/etc/systemd/system/couchpotato.service; enabled) Active: inactive (dead) since Mon 2017-07-24 16:49:08 -04; 10min ago

Jul 24 16:49:03 OkupaCenter systemd[1]: Started CouchPotato application inst....

If I try starting the service manually I get:
osmc@OkupaCenter:~$ sudo systemctl status couchpotato.service -l
* couchpotato.service - CouchPotato application instance Loaded: loaded (/etc/systemd/system/couchpotato.service; enabled) Active: inactive (dead) since Mon 2017-07-24 16:49:08 -04; 13min ago

Jul 24 16:49:03 OkupaCenter systemd[1]: Started CouchPotato application instance.

I dont get why the services is LOADED but then is inactive (dead) Any clue?? Thanks


Did you try to make backup, remove it and install again? Then check if it works? When work, then try to restore data nd check again if it works. Maybe did get something wrong with updating.


At the end I removed everything and install again. Now its working. As you said, I think that couchpotato stop with the last OSMC update or couchpotato update. Anyway, now is running as always.

Thanks for the help


How can I fix now that is takedown? I thing that the new repo is My installation can’t get updates anymore and show an error bc of repo down…


Ask the SickRage guys I think…


In the NEWS section of your sickrage webpage, this is the last news:


A false DMCA takedown request was sent to GitHub, resulting in multiple repositories, including SickRage/SickRage, to be taken down. We’re countering this and should have the repo back very soon. We thank you for your patience.

Just be patient and wait for the fix.


i keep getting file is locked for reading/writing when trying to process the files… any idea how to solve this?


Hello, Any idea if fix is done? I can install sickrage from new github location, I can run it manually but not as daemon.


I will try to make new scripts soon, but I would like to know what would you prefer more?
SickChill or Medusa?
Couchpotato or Radarr?
Because now I’m testing medusa & radarr with nzbget for like a month and a half.