How to install XMLTV on OSMC?

TVHeadEnd 4.0.7
Schedules Direct subscription

I’m trying to eventually load Schedules Direct data onto the TVHeadEnd EPG, but first it seems I need to get XMLTV up and running.

I have set up my HDHomeRun Connect, mapped my ATSC network with muxes, services, and channels, selecting the channels I want. Tried using the EIT, but nothing shows up on the TVHE EPG listing, though oddly Kodi does now have guide information, albeit with shows mixed up on the wrong channels. Attempts to record fail due to channels not found.

I don’t see XMLTV as part of the OSMC build and can’t find anything on how I install it on OSMC. The posts that refer to it seems to start from the point that it is installed. Have I missed something?

1 Like

Generally OSMC is based on Debian Jessie so if you google xmltv debian jessie you will find most likely some information. While the following command most likely brings you to your target sudo apt-get install xmltv-util

Thank you, this answer encompasses both the specifics I have now, and will help with future aspects of my OSMC education.

I know this is an old thread but it does pertain to my current status.

I have, thanks to so many on this forum, got OSMC to reliably record to my NAS drive and now only getting the EPG to work remains.

I tried using Ronnie Bailey’s youtube video: Installing zap2it grabber in OpenELEC - YouTube which installs Zap2It as a Program addon [albeit in OpenElec].

I downloaded per the video: GitHub - edit4ever/zap2xml: zap2xml in Python 2.7 for use on LibreELEC and OpenELEC systems and I also made sure it was the latest version and the UPDATE command on the addon verified this.

The installation per his video went fine and I entered my e-mail/password and it appears no errors were generated and the addon is shown as running on my server. xmltv-util is installed on my OSMC/RPi 3 and current.

However, when I log on to the TVHeadend web page for my OSMC/RPi, and try to configure the “EPG Grabber”, the "XMLTV:tv_grab_zap2xml… " does not appear in the “Internal Grabber” drop down box.

Yesterday just to check on Zap2it, I installed it on my Win 7 pc and was able to create an XML file containing all the needed EPG data.

I don’t have a direct answer to your problem. It could be that the plugin you are trying is expecting TVheadend from the LibreELEC plugin and doesn’t play nice with the build you have?

The zap2xml I mentioned in the other thread is a completely different program, by a different author, and works as an external grabber, (as opposed to an internal grabber that your zap2xml is). Maybe you’d have better luck with that?