How to limit audio bit depth to 24 bit?


I am very much enjoying my new Vero 4K, but I have the following problem when playing material with 7.1 audio.

I have a receiver that supports 7.1 LPCM audio over HDMI, up to 96 KHz/24 bit.
The receiver does not support audio passthrough of TrueHD and DTS-HD.
Thus, I have disabled “Allow passthrough” in order to have Vero 4K decode to 8-channel LPCM. The decoded signal is, however, 32 bits, 48,000 Hz (as shown on the info panel during playback). This causes my receiver to only output 5.1 audio.

I have two questions:

  1. I was of the belief that TrueHD did only support up to 24-bit depth audio. Why does Vero 4k then output 32-bit, even when “Best Match” is selected in Output Configuration?
  2. Is there a way to either have Vero 4K output the actual bit depth of the material, or a way that I can limit the bit depth?


Anyone? :slight_smile:


Sorry – somehow I missed this post.

  1. It’s being streamed as LPCM, and decoded losslessly using dcadec.
  2. Usually it tries to do a best match, but this depends on the receiver’s advertised capabilities and the SoC’s capabilities.

I don’t think you’ll hear anything different, but if you can elaborate on the problems you are experiencing I can take a further look


FFMPEG decodes to 32bit. If your sink only supports 24bits, then the last 8 LSB will be discarded. Nothing gained, nothing lost. Business as usual.

Thanks for your replies.
My receiver (Panasonic SA-XR700) supports LPCM up to 8 channels at 96 kHz/24 bit over HDMI, according to the manual.
The problem I am experiencing is that when I play content with 7.1 audio, my receiver only outputs 5.1, i.e. the SBR, SBL channels don’t output any sound.

I was assuming that the problem might be that OSMC outputs 32 bit audio which can not be handled by the receiver, but I assume that the problem could also be that the receiver does not advertise it’s capabilities properly.

How can I check the advertised capabilities?

Thanks for your support.

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/aud_cap
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
PCM, 6 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
PCM, 8 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz, 16/24 bit
DTS, 6 ch, 32/44.1/48/88.2/96 kHz, bit
Dobly_Digital+, 8 ch, 44.1/48 kHz, bit
MAT, 8 ch, 48/96/192 kHz, bit
DTS-HD, 8 ch, 44.1/48/88.2/96/176.4/192 kHz, 16 bit

Below is the output from my Vero. It seems that the capabilities are advertised correct by the receiver. The question then is why the receiver does not receive 8 channel audio. Is there anything else of relevance that I should check? Can I check what is actually sent to the HDMI output during playback?

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/aud_cap
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
PCM, 8 ch, 32/44.1/48/88.2/96 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz, bit
AAC, 6 ch, 32/44.1/48 kHz, bit
DTS, 6 ch, 32/44.1/48/88.2/96 kHz, bit


This issue has been solved. Thanks for your help and input.

It turned out that the receiver has a bug related to its “Advanced Dual Amp” system, resulting in no sound in the SB speakers for 8 channel input, when the system is enabled. Simply disabling this system solves the issue.

I did encounter another minor issue. When DTS passthrough is enabled and DTS HD passthrough is disabled, Vero 4K still opts to passthrough the core DTS signal to my receiver instead of decoding the DTS HD-MA track to PCM. Is this the expected behaviour?

What receiver do you have? Might help other users in the future.

Yes – I believe that’s correct. If you want the LPCM output for everything, just disable passthrough and set channels to 7.1.


The receiver is a Panasonic SA-XR700.

I recommend using passthrough whenever you can, even DD. This amp can not upscale 5.1 LPCM audio to 7.1. But it will do so for passthrough audio using DPL 2x. Most probably you cannot distinguish between lossless and lossy audio. (But I am not about to argue further over this, it’s your amp so feel free to disregard my recommendation)

Maybe some day Kodi itself will be able to upscale 5.1 to 7.1 (or more)…but that’s in the future.

I would definitely want to use passthrough for DTS in order for my receiver to be able to upmix to 7.1, but DTS-HD sometimes includes 7.1 audio, in which case I wouldn’t want to use the core DTS 5.1 audio. In that light it seems curious to me that the DTS core is passed through for a DTS-HD movie, when DTS passthrough is enabled and DTS-HD passthrough is disabled.
If the DTS-HD only has 5.1 audio, I agree that I might opt for passing through the 5.1 DTS core instead in order for my receiver to be able to upmix to 7.1 though.

For now I guess I will have to enable/disable passthrough of the DTS core of DTS-HD titles on a per-movie basis, depending on whether they have 5.1 or 7.1.

As you say, hopefully, Kodi will at some point be able to upmix to 7.1. Maybe when AudioDSP is working again (if it ever will)?

I believe that there’s been quite a bit of progress with AudioDSP, and that
a working version will land in Kodi v18. As such, I suspect we’ll see some
early working version of it landing in one of @gmc’s Kodi v18 nightlies for Vero
4K soon enough.