How to make Wake On Lan work

After using OSMC for more than a year I finally got something I can’t figure out…

I use this configuration:

  • Raspberry Pi 3B
  • OSMC March 2018.03-2
  • Samsung TV UE32EH5300

The Pi is connected to the TV using HDMI cable, and is connected with a wire to the network.
It has a static ip-address.

Now I want to set it up for Wake On Lan. I am a noob with networks and WOL, so please bear with me.

I go to settings in Kodi and I have the option only to setup a timer, of any length I choose, OR “off”.

I choose say, 5 minutes.

After 5 minutes, sure enough the Pi goes to sleep.

I use “Kodi Remote” an iPhone App, it offers a “Wake on Lan” option. The Kodi shows as “offline” and I select it and choose the WOL option. It says command send, but nothing happens.

The TV shows “no signal source” and I try different buttons on the remote, just to be sure. Switch HDMI channel in hopes the HDMI might trigger something.

Nothing works. I finally try to ping the device from my computer; not working either. I googled and found a freeware program to “wake up” computers using WOL. I enter IP address, MAC Address and click the magic button, this doesn’t work either.

I looked at the Wiki pages (Wake on lan - Official Kodi Wiki) and noticed a “wakeonlan.xml” for userdata. You can enter your MAC address in it, and IP address. I decided to give that a go. I restarted after adding the xml and tried all things again.

Not working.

The device goes to sleep ok, it just never wakes up. Any ideas for me ?

Sidenote; I saw a screenshot of Kodi settings (Oct. 2017 I think) it offered way more options on the “Energy Saving” page. I only have 2 options: timer and if I want to wake up servers (??) …

Unfortunately, WOL relies on having a BIOS that is listening for the magic packet on the network interface. AFAIK, the Raspberry Pi does not have such a BIOS - and, unlike “normal” PCs, its network interface chip is connected over the USB bus.

https://www.raspberrypi.org/forums/viewtopic.php?t=39714

I was considering implementing a poor man’s virtual Wake on Lan for our Vero 4K suspend feature.

Surely we can capture the packets from userland and respond accordingly?

Sam

ahhh ok, so that actually makes sense. I was thinking “it’s in the settings, so it must work” but of course this software can be used on many machines, including computers in which you configure the bios accordingly.

Makes so much sense, thanks !

After using OSMC for more than a year I finally got something I can’t figure out…

I use this configuration:

Raspberry Pi 3B
OSMC March 2018.03-2
Samsung TV UE32EH5300
The Pi is connected to the TV using HDMI cable, and is connected with a wire to the network.
It has a static ip-address.

Now I want to set it up for Wake On Lan. I am a noob with networks and WOL, so please bear with me.

I go to settings in Kodi and I have the option only to setup a timer, of any length I choose, OR “off”.

I choose say, 5 minutes.

After 5 minutes, sure enough the Pi goes to sleep.

I use “Kodi Remote” an iPhone App, it offers a “Wake on Lan” option. The Kodi shows as “offline” and I select it and choose the WOL option. It says command send, but nothing happens.

The TV shows “no signal source” and I try different buttons on the remote, just to be sure. Switch HDMI channel in hopes the HDMI might trigger something.

Nothing works. I finally try to ping the device from my computer; not working either. I googled and found a freeware program to “wake up” computers using WOL. I enter IP address, MAC Address and click the magic button, this doesn’t work either.

@quynhido08 can you explain why you copy/paste the post from @MorganBateson and opened a new thread?

That is odd to say the least. Any mod available may close this topic as well. I don’t seem to be able to myself

No worries, he/she actually put it in a new thread and I moved it over here. And then only saw it was a copy/paste.
Most likely just a spammer. I will keep an eye on that account. I think for the time being no need to lock this thread as maybe someone still has a question even so all answers are already given and I already marked the respective post as “Solution”.