How to output MONO audio?

Hi all, my first post here!

I run OSMC on a PI3 connected to an oldschool CRT TV which has only a MONO audio input so I’d like to configure OSMC to output MONO audio. This means L+R are mixed together in both audio channels.

I’ve been looking a lot on settings for this usually easy option with no luck. Is that possible at all? Maybe with a plug-in?

Any help is appreciated,
thanks!

How do you feed the signal in? Via the 3 pole headphone port? If so an adapter like this should work.

https://www.ebay.co.uk/i/184086778014?chn=ps&norover=1&mkevt=1&mkrid=710-134428-41853-0&mkcid=2&itemid=184086778014&targetid=878706529565&device=m&mktype=pla&googleloc=1006552&poi=&campaignid=9794911374&mkgroupid=101625064684&rlsatarget=aud-381667280803:pla-878706529565&abcId=1139126&merchantid=113416567&gclid=Cj0KCQjwzN71BRCOARIsAF8pjfhPOTq0puRRILb-QhjcRU19wSije525v1F5gPkRdtbw4Ob7wR8OvjgaAvokEALw_wcB

Thanks, yes an adapter is an option but I was hoping on a software solution.

Also it seems like most adapters are splitters, a joiner requires some more stuff like a resistor or something.

It should be fairly trivial to hack up a cheap cable and insert a couple resisters…

https://www.raspberrypi.org/forums/viewtopic.php?t=138669#p944106

Yes but a software solution would be cheaper and neater. Also adding to the signal could introduce noise or reduction, software would be much better. In the same link they also suggest to change some ALSA settings. Now I can set ALSA as output in OSMC but I can’t find any of the files they suggest on the topic. Isn’t ALSA insalled by default in OSMC?

ALSA is there all right. Make a file called .asoundrc in /home/osmc with the contents suggested but adding a hint

# mono
pcm.mono {
	type route
	slave.pcm "hw:0,0"
	ttable {
		0.1 1
		0.0 1
		1.0 1
		1.1 1
	}
        hint {show on description "Mono analog"}
}

You may also have to type this sudo amixer cset numid=3 1 not too sure.

Restart kodi and you will see an extra entry in the audio settings. It won’t say “Mono analog” (getting too late for me to work out why) but if you experiment you should find one setting that gives you mono output.